Google site my website is down and dns not working

*I have recently changed my domain registrar to cloudflare.
*My old website was hosted on Godady and I moved contents to google sites.
*I have followed all instructions to the letter to connect my domain to my site, but it is not working at all, my website is not visible to visitors any more. I have read the articles on this help forum and I’ve tried many suggestions to resolve the error but nothing is working. Visitors get the error "404. That is an error. The requested URL / was not found on this server. That is all we know.

The error is because there’s no valid DNS record for the Make sure to add a record as in the image.

For more info, check the following Tutorial


The www hostname doesn’t work, either, indicating a problem with the origin server at Google Sites. Best to pause Cloudflare, or set the corresponding hostnames to :grey: DNS Only, and resolve the Google Sites issues first.

There are also a lot of leftover :orange: Proxied GoDaddy cPanel CNAMEs that could stand to be cleaned up to eliminate some of the useless visual noise in the zone.


Thanks for your reply!
I tried that, still doesn’t work :frowning: (
What else can I do?

Is there a “correct” or “default” DNS records screen_shot that I can follow to make things work? I am no technical and find it difficult to understand the big picture of the correct settings.
I am grateful for your assistance.

By default a zone starts out empty. You had records created by your GoDaddy cPanel hosting. When you moved your DNS to Cloudflare you brought those records over. You then added Google Sites records, though possibly not according to their directions since you are having 404 errors.

You may wish to review the process in the Google documentation.


HI, I have cleaned all the stuff from my DNS, and started fresh, done everything according to google_sites directions, still no joy, but the error message has changed to : This page is not redirecting properly etc…, there is no “too many redircts”. My SSL/TLS is set to full and there is no page rules created. screen capture attached, thanks for anticipated help.

Can you confirm that your SSL/TLS encryption mode is Full (strict)?


@joewayne Apart from the mentioned error, I see the ip address you’ve entered seems a wrong one (dummy one). Instead insert the real values.

I am reasonably certain that the dummy IP is to accommodate an originless redirect, such as a Page Rule or a Redirect Rule. I am successfully redirected from the apex name to the www host before the redirect loop begins.


What is the dummy IP and where is it? If you point me to this perhaps I can delete it, Thanks.

Yes, see screen_shot.

I am not able to understand where is the dummy IP or how to correct it.

Also, where are the real values and how do I get them and where to insert them?
Sorry I am not technical. is the dummy IP. If you have a redirect rule in Cloudflare for do not delete it.

Your screenshot shows Full. You want Full (strict) or Cloudflare will accept invalid origin certificates.

Can you switch just your www name to :grey: DNS Only and see if the redirect loop clears?


I’ve deleted the entry showing the dummy IP, I have changed the encryption mode to full (strict) and switched the www to DNS only.
Nothing works. :confused:

The error message changed to: Seure connection failed. An error occured during connection to the website.
The page you are trying to view cannot be shown because the authenticity of the received data cannot be verified.

@joewayne Add a record like following image. Change the ip address to the one you’ve received from the host. See the first image you’ve posted. The ip address is listed there begins with 148.

That is the retired cPanel hosting, @neiljay. The content is on Google Sites now. That’s why I shared the Google documentation earlier.


OK, I have done this, now I back to error 525, SSL handshake failed! Man this is so crazy.