Google Search Console integration removed CNAME record


I used the Google Search Console(search dot google dot com) to add my new domain, I added the google-site-verification record by using the Cloudflare integration.

Today my website stopped working, looking at the DNS the CNAME for the Cloudflare Pages was gone. Looked at the audit log, the second before the integration function added the google-site-verification record, the CNAME record for the Cloudflare Pages was removed.

Don’t know who is responsible for the integration, but it is buggy.



I just experienced the same bug.

When adding a comain to Google Workspace, the process prompts to sign into Cloudflare directly to add the verification TXT record. However, Cloudflare seems to think that the verification TXT record for the root domain would replace an existing CNAME record for the root domain. And, if I click “Authorize”, it would actually remove the existing CNAME and add the verfication TXT record.

+1 for this! I was going to click authorise until I noticed that it was going to remove my GitHub Pages subdomain, which would have brought my site down :frowning:

Do we know any fix or way around this? Or do you just have to click replace and then add the CNAME record back afterwards.

+1 this happened to me yesterday, brought the site down.

Hi, I let google do it because I think why not? And my site brought down. Can someone found a way around it. I readded Cname file manually from logs but site is still crashed. Tried to re upload everything to my github again (I am using github pages for my site) and it is still not working.

Can someone please give info how to fix it?