Google Merchant blocked by Super Bot Fight Mode


I got a notification from google merchant that the feed has an error. The feed had a global issue of authentication failure. I tried fetching the feed again and it failed.

I then set the Super Bot Fight Mode to “Allow” bad bots and then tried fetching the feed again which was successful. So I assumed google merchant was behaving the same in both attempts. If it was using the same IP and the same request then the Super Bot Fight Mode was blocking this request.

Then I did this re-tested several times and had the same results when in “Challenge” google failed and in “Allow” successfull. I am pretty confident Super Bot Fight Mode blocks GM good known bot.


It’s quite possible that Google Merchant isn’t considered to be a “known bot”, in which case you can’t use SBFM.

That’s odd as this is very widespread tool in most ecommerce websites.

Can I make a rule to bypass the SBFM on a specific URL?

Unfortunately, at this time there is no way to bypass SBFM like that.

Any idea if and when such functionality will be available?

What would be the alternative approach to block bad bots using the firewall?

I am having this same issue. Every-time I want to upload or update a feed I need to manually turn off SPFM wait a few minutes then run the upload. We have several feeds and this is not ideal. Has anybody figured out what to do?

Maybe the tool was launched as it helps reduce the load on cloudflare - when bots cant get access eventually the traffic reduces and maybe it is not too functional so it doesn’t harm the income coming from the other CF programs.
Strange they didn’t provide a bypass.

This is not just happening with SBFM. Regular Bot Fight Mode is also blocking Google Merchant.

My website is broken. Please help CF!

This topic was automatically closed after 30 days. New replies are no longer allowed.