Google DNS txt verification failure after 3 days

Hello,
I’ve read many of the existing posts but it appears that the TXT record is correct in my Cloudflare DNS.
When I verify the record Google returns the 3 other txt records in my DNS properly but not the Google entry.
NAME: mysite.ca
CONTENT: google-site-verification … (Copied and pasted from google)
PROXY STATUS: DNS only
TTL: Auto

I’ve been trying to verify this for 3 days without success.
Thank you

What is your domain?

www.hairclippers.ca

When I do a lookup for a TXT type using DIG command, I get this:

;QUESTION
hairclippers.ca. IN TXT
;ANSWER
hairclippers.ca. 300 IN TXT "google-site-verification=K5csdsaDUhQeyX8oIlupMMdSlO15EVJHO8aDCEisy6k"

And both A @ and A www DNS entries are added to the DNS tab of Cloudflare dashboard as far as I can check too.

Despite the fact for www.hairclippers.ca there is no TXT records.

So, the question might be, did you added with or without www prefix to the Google Search Console / some other Google product vs DNS hostname at Cloudflare? :thinking:

What comes to my mind might be, we could flush the DNS cache at Google / Cloudflare, if so using below tool for TXT type of your domain and www domain, if that could help a bit:

I wonder if Bot Fight Mode could interference with this so far, or something else which might be blocking Google at Cloudflare, like Firewall Rules or similar? :thinking: (I doubt, but …)

Greetings,
I may be an old assembler/COBOL/BASIC programmer but most of this stuff is beyond my area of expertise and I am dependent on multiple levels of support. When my tech person turned me on to Cloudflare he set up the site. When seen from my Cloudflare home page the site is hairclippers(dot)ca. That translates to my Rebel(dot)com registrar which in turn points to my wordpress website which is https(://)www.hairclippers(dot)ca/
Tech support added Bot Fight Mode and other Firewall rules as I was getting hammered by Spam bots and my credit card payment provider was extremely concerned and sending me warning emails.
Problem started because Google was removing my website from my Google profile almost monthly. I was recently made aware that Google was not indexing any pages on my website by my web support although Firefox and other browsers had no problems. I had originally entered hairclippers(dot)ca in my Google Search Console but later today entered https(://)www.hairclippers(dot)ca and things started to move forward with notification of site ownership verification. I can see in the Console that all my pages are excluded due to “Blocked due to access forbidden (403)”
If you can find any problem with the above information please let me know. I am more than extremely grateful for the advice and time.

Hm, we can try something.

Thank you for feedback information and sharing domain name.

As you mentioned your WordPress website was caught in some attacks and so on, therefore Cloudflare team helped you by adding a security measurements to protect and secure it, but this now seems to be a bit to strict by what I do understand from reading your feedback information.

If you are having trouble validating a TXT record with a 3rd party service (Google in your case), when signing up for it, you could temporary switch and make sure the record is :grey: and not :orange:.

Can you navigate to the DNS tab of Cloudflare dashboard for your domain name and look up for A hairclippers.ca or A www (or maybe a CNAME).

Otherwise, you can try by using an option “Pause Cloudflare for this Website”.

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Retry the Google TXT verification process.
  5. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Nevertheless, if this continues, we might have to troubleshoot and question you to double-check for us your Security settings like Security Level, Firewall Rules, Bot Fight Mode option and similar, just in case.

Hopefully, your WordPress is configured to allow indexing/robots to access your Website, or else Google might respect those settings and not index your URLs.

If so, we could also try to whitelist Google IP ranges or Googlebot so it passes by.

I’ve been browsing in my Cloudflare Firewall log and Cloudflare was (IMO) definitely blocking the googlebots in ‘bot fight mode’. IP address matched list of those found at https(://)developersdotgoogledotcom/static/search/apis/ipranges/googlebotdotjson
I flagged 2 of those to be excluded. There are a several ranges of googlebots so I don’t know whether or not the same IP addresses will be used going forward from today.
Any further suggestions?

Can you please post a screenshot of that block event?

That sure looks like you have a Firewall Rule called Known Bots set to Block cf.client.bot.

Granted, this has nothing to do with DNS, but it would be the source of the console error you’re seeing.

Tech support added Bot Fight Mode and other Firewall rules

Cloudflare’s tech support doesn’t make changes to user accounts, except in extreme circumstances on Enterprise Plans. Who actually made these changes?

Yes, going through the list I can see several indexing bots are blocked by both Firewall rules and bot fight mode. Not only Google. If I exclude the ASN will that be the quickest/broadest fix to the problem?

Just turn that rule off. Known Bots should play by the rules and will not crawl /feed/ if you tell them not to in robots.txt.

I am not familiar with ‘robots.txt’ I was told that none could be found on my website.

I have turned off Firewall rule for known bots. Will have another look this evening. Thanks as always for your assistance and time.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.