Google _dmarc - DNS TXT - not showing

Hello how are you,
around 1 week ago i added the TXT record for _dmarc verification at my domain in cloudflare, but somehow is still not appearing, tried to modify a little bit today and nothing.

url: purisco.com

DNS Record:

TXT
_dmarc
v=DMARC1; p=none;

If someone can help would be great, thank you!

Greetings,

When I query the _dmarc.purisco.com I can see it as you’ve stated v=DMARC1; p=none;

;QUESTION
_dmarc.purisco.com. IN TXT
;ANSWER
_dmarc.purisco.com. 300 IN TXT "v=DMARC1; p=none;"

I can also see the TXT for the SPF and DKIM exists:

"v=spf1 include:_spf.locaweb.com.br include:_spf.google.com ?all"

Nevertheless, while checking however I cannot see the DKIM as for default._domainkey selector :thinking:

May I ask did you added one or using a different selector?

EDIT: My bad, as far as I can see by the MX record for your domain name, you’re using Google Workspace, meaning should be google’s selector google._domainkey.

Did you enabled and are using DKIM at Google Workspace admin at all or not yet implemented it?

Helpful article here:

2 Likes

Hello, thank you for your fast answer,
yes i’m using google workspace thats why that record is there. thanks for the article.

I’m sorry but i still can’t see the dmarc records through my verification, where are you checking?

Multiple sources, online and my terminal/console.

Sharing here:

May I also ask what service or how do you check for it? :thinking:
Could be due to possible DNS cache at your ISP so you don’t see it (yet).

Hello, very similar sites and console as you,
and other websites

https://dnschecker.org/all-dns-records-of-domain.php
https://mxtoolbox.com/DNSLookup.aspx

I’m not in doubt for your answer but is funny that this record hasn’t showed yet,
maybe i’ll ask another source to check it for me, maybe my region is not reading it.

Thank you,

– edit
if i query purisco.com, and see the TXT the record won’t show
but when query _dmarc.purisco.com then i can see the record there,

is that normal? thank you

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.