Google couldn't find an ads.txt file

Hello everyone, I’ve also been having issues with ads.txt for the past few days. I didn’t understand what Cloudflare did with the update that messed everything up.

So, here’s the situation: I have the ads.txt properly placed on the hosting and easily accessed through virtualeestudio.com.br/ads.txt.

However, Google’s robot can’t access it:

“We couldn’t find an ads.txt file. We tried to locate a file at virtualeestudio.com.br/ads.txt, but without success. Please check if you uploaded the file correctly and if it’s available to the AdSense Crawler.”

The rules on Cloudflare are as follows:

Page rule:

  1. http://www.virtualeestudio.com.br/

    • Always Use HTTPS
    • Disabled
  2. https://www.virtualeestudio.com.br/*

    • SSL: Flexible, Rocket Loader: On, Automatic HTTPS Rewrites: On, Opportunistic Encryption: On
    • Enabled
  3. www.virtualeestudio.com.br/*

    • Disable Security, Auto Minify: HTML, CSS & JS, Security Level: Essentially Off, Cache Level: Bypass, IP Geolocation Header: On, Email Obfuscation: On, Origin Cache Control: On
    • Disabled

In Security > Settings:

  • Security Level:
    • Essentially Off
  • APIHelp Challenge Passage:
    • 1 day
  • Browser Integrity Check:
    • Enabled

when I hit more than some times virtualeestudio.com.br/ads.txt I see a challenge cloudflare page, zero trust, but here in settings I dunno where it is, or how to disable it, can’t see it as enabled here.

I tried AI solutions ( bard, gpt 4)
but can’t solve!

please guys may u help me?

#ads.txt #pagerule #settings Website, Application, Performance Security DNS & Network

At some point you have set up a Zero trust access application for your site.

Go to “Zero Trust” in your Cloudflare account, then “Access”, then “Applications”. You will see it in there. If you don’t need it, delete it.

[add] I guess you’ve just found it, it’s now showing your site and ads.txt is appearing ok.

1 Like

understand.
so when I hit in safari, can access well the ads.txt not problem.
but if I try repeatedly access directly without the www we go to the challenge page, but the code never goes to the email.

but google can’t access the page it I dunno why.
the zero trust Im trying to find here!

I saw this message: in Access menu:

Access

Protect self-hosted, SaaS and private applications with Zero Trust policies. Only users who match your policies will have access to your configured applications.

Access documentation

Configuration for Access has moved to Cloudflare Zero Trust as of May 25, 2022. This page has been deprecated. All existing functionality, as well as new features, is available in Zero Trust.

Access protects internal and SaaS applications behind Zero Trust policies. With Access, you can control which users and groups can reach your resources without a VPN or making code changes to your site.

Press the “Launch Zero Trust” button, look in there for “access”.

The normal place to go is to select “Zero Trust” from the side menu from your account page here:
https://dash.cloudflare.com/?to=/:account

1 Like

I have no setting’s here.


I found it, If I let in blank , it can help ? or stop the block google crawler bot:


Strange, you are definitely being redirected to access. Someone else may know other places where access can be triggered.

What DNS records do your have for @ (virtualeestudio.com.br) and www here…
https://dash.cloudflare.com/?to=/:account/:zone/dns

curl -I https://virtualeestudio.com.br/
HTTP/2 302
date: Sat, 23 Dec 2023 15:36:18 GMT
location: https://virtualeestudio.cloudflareaccess.com/cdn-cgi/access/login/virtualeestudio.com.br?kid=ab38a8bbad9982c13bd331a6ddd8a5f850ef4d929cbe4f4e7224b73abb29b835&redirect_url=%2F&meta=eyJraWQiOiJjY2JiZGQzYzVjMDI4OWZjYjgwMjg3NzhmMDdjMGY0MDkwYzY0OThhMWNmOTUxZjFiNmUzZmM0NDQ0Mjk5MTM5IiwiYWxnIjoiUlMyNTYiLCJ0eXAiOiJKV1QifQ.eyJzZXJ2aWNlX3Rva2VuX3N0YXR1cyI6ZmFsc2UsImlhdCI6MTcwMzM0NTc3OCwic2VydmljZV90b2tlbl9pZCI6IiIsImF1ZCI6ImFiMzhhOGJiYWQ5OTgyYzEzYmQzMzFhNmRkZDhhNWY4NTBlZjRkOTI5Y2JlNGY0ZTcyMjRiNzNhYmIyOWI4MzUiLCJob3N0bmFtZSI6InZpcnR1YWxlZXN0dWRpby5jb20uYnIiLCJhcHBfc2Vzc2lvbl9oYXNoIjoiMDFmM2ExYTkxYWFkYWQ3ZWZmZTVhMDk0ODAwNzY4MWVjNTBhNTFlZWNjNDJmZjUzZTMxMDhjMzhiZWRmMTQxMCIsIm5iZiI6MTcwMzM0NTc3OCwiaXNfd2FycCI6ZmFsc2UsImlzX2dhdGV3YXkiOmZhbHNlLCJ0eXBlIjoibWV0YSIsInJlZGlyZWN0X3VybCI6IlwvIiwibXRsc19hdXRoIjp7ImNlcnRfaXNzdWVyX3NraSI6IiIsImNlcnRfcHJlc2VudGVkIjpmYWxzZSwiY2VydF9zZXJpYWwiOiIiLCJjZXJ0X2lzc3Vlcl9kbiI6IiIsImF1dGhfc3RhdHVzIjoiTk9ORSJ9LCJhdXRoX3N0YXR1cyI6Ik5PTkUifQ.NZzPbwLWyGr4fNC20BhpXI8rNgBJeF5nIK36UjQuoQ1fueNZYK_qpfqOqbK3XusgylPjqph0xcMnhtI0YpO4C2X_JxYoakg0j7JVMPw1RGPWCHzu3NB-xql_8OhUUVhL2ci8EJ0xm40RCmX6ErChZdle8Rg9T6TfQnfyw82-reNJkWj825CDbTdgXl1sInljV4kh1-FeO4Dl0GzYh6t-H_hPDxKiJvmXjUWGvMbKCoFwGyuLwIxF6vCQ8FpUMJYELytwX6vVbVZrduqR7KqQR1KMPziCdNqYeNyR31rrlQaGl388M8KY4HNhxYkwvsNnoFH5LQanIeCYFH9Vh2RmAg
set-cookie: CF_AppSession=n53c52923097b5fd8; Expires=Sun, 24 Dec 2023 15:36:18 GMT; Path=/; Secure; HttpOnly
access-control-allow-credentials: true
cache-control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0
expires: Thu, 01 Jan 1970 00:00:01 GMT
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=cs9YhCbIqLRfZc5JP9P%2Bb5r7jGXyljp4BIAm7Bzmmu2iDtDIidVwMJp0eQY15ssx0F89chE%2BADpUGgMqtzO%2FUOsC6CFewVZ2Kek7wkjlP6GzcITkO7oe77nVMJJmNrJxeiPG58RqHFVq"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
strict-transport-security: max-age=0; includeSubDomains; preload
x-content-type-options: nosniff
server: cloudflare
cf-ray: 83a1adebfb986412-LHR
alt-svc: h3=":443"; ma=86400

That’s just configuring the page, it’s not what triggers it to appear for your domain.

1 Like

these one:

im exploring new possibilities …
do you know how I disable this thing?
I was notice my site isn’t opening when hit: virtualeestudio.com.br
which rule should I change?

I put the same question on google, and the experts there are saying my site isn’t opening when just type: virtualeestudio.com.br
Screenshot 2023-12-26 at 7.22.45 PM

and for this reason the ads.txt can’t be verified by google!

I thought I put the rule that force https, or redirect all the times,…

Do you guys know how can I set up it here on rule? I’ll try change it the put the crawler to run again, maybe can I get the solution!

Protect self-hosted, SaaS and private applications with Zero Trust policies. Only users who match your policies will have access to your configured applications.

humm im trying to find theses configs u told.

im using today morning AI to identify conflicts, I deleted the bucket S3 on amazon server, now trying to reconfigure with cloudflare, the site is online but inaccessible, after let it online again, ill search this thing zero trust, but how I use free cloudflare account these paid rules I do not have here no.

You have an access policy in place as @edduvaz indicated. Randomly deleting an S3 bucket won’t have an effect. It now appears you’ve deleted the DNS hostname so nothing resolves. Your screeenshot is not an access polict. That would be in the section labeled “Access” on the righthand menu.

1 Like

interesting

Hey @cloudflare support how can I delete a service that I don’t have? to delete I have to choose a plan and put credit card! WTF im in Brasil, even if IF I pass one dollar, it will be converted to our currency, plus GOV TAX, plus interenational buy GOV TAX, plus credit card GOV TAX, in dollars its like pay 50 bucks! I won’t.

I thing should have a way without PAY NOTHING, to remove this thing of zero trust that is causing trouble here, I deleted the amazon buckets, rebuilt the problem isnt there, im rebuilt all dns records here. but the zero trust I can’t remove!!!


@cloudflare support may u give a hand here?

Se acalme. Choose a plan. It was added through an alt mechanism that didn’t require a plan selection at that point. But that’s where you edit it.

All the other steps you’ve taken have no effect because they weren’t the steps required. If those were required @sjr would have instructed that as apart of the remediation.

1 Like

Unless you exceed the limits of the Zero Trust free plan there is no change.

Since you’re not planning ot use it, that doesn’t seem to be an issue. Choose a plan.

I’ll try free plan to see …
but is unfair!