Google Chrome on Windows - Error code 520

We recently migrated to Cloudflare from GoDaddy and one of our team members keeps getting an error code 520 on Google Chrome in one of our subdomains - https://app.tapmyback.com.

The same issue does not happen with other browsers or even in incognito mode. And other DNS records doesn’t seem to be affected by the same issue. Other team members with the same setup (Windows and Google Chrome) were not affected.

We already tried the proposed solutions on Cloudflare Help Center https://support.cloudflare.com/hc/en-us/articles/115003011431-Troubleshooting-Cloudflare-5XX-errors#520error, but could not solve the issue. Pausing Cloudflare or Disabling the proxy (DNS only) fixes the issue, but we would like to keep the subdomain proxied to have the advantages of Cloudflare. Besides that, we already have tried cleaning the DNS cache on the computer (Windows), different networks, changing the Wi-Fi DNS and reinstalling Google Chrome.

We have collected some info that could help understanding the issue.

  • cf-ray
fl=40f69
h=app.tapmyback.com
ip=148.69.168.220
ts=1675440482.086
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/109.0.0.0 Safari/537.36
colo=MAD
sliver=010-tier1
http=http/3
loc=PT
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off
kex=X25519
  • HAR file with Cloudflare enabled - https://cdn.tapmyback.com/website/with_cloudflare_active.har
  • HAR file with Cloudflare disabled - working fine but not the ideal solution https://cdn.tapmyback.com/website/with_cloudflare_paused.har

What else can we try to solve the issue?
How can we understand if other users might have the same problem?

Thanks in advance for your help!

You are not the first to encounter this with GoDaddy, just :search:

If I had to make a wild guess, perhaps GoDaddy has some strange DDoS protection that resets connections when it sees too many from the same IP, which will happen with Cloudflare since it is proxying the connection. In none of the GoDaddy threads I found, did I see a solution. If there is one, it’s going to be on GoDaddy’s end anyway, so you’re best off asking them for help.

ps. Those HARs do not seem to be correct, it looks like whoever collected them just saved the requests that were made when they had google’s home page open. They appear to have their Google Session ID and a few other cookies/potentially sensitive information as well, so you may want to remove them.

HAR files contain all request’s body/headers, cookies, and other potentially sensitive information.
Cloudflare has a guide on HARs here:
https://support.cloudflare.com/hc/en-us/articles/203118044-Gathering-information-for-troubleshooting-sites
Like it says though, "A HAR file can include sensitive details such as passwords, payment information, and private keys. Manually remove sensitive information from a HAR file via a text editor before providing to Cloudflare Support. "
I do not think a HAR would be helpful with this either way though.

Hi Chaika

Thanks for your answer and notice on the HAR files, we have removed them.
Regarding the issues you shared, we have also found some threads with the 520 error but in our case the DNS it’s currently managed on Cloudflare, so it should not be an error with GoDaddy. The thing that had us scratching our heads it’s that it only happens on that specific case, it doesn’t happen with different browsers or even with an anonymous session.

Those issues I linked above were from people who have their DNS with Cloudflare, but using GoDaddy as their web host still, on a proxied :orange: record. It seems under those conditions GoDaddy has 520 errors.

Regardless of who your web host is, you’ll have to reach out to them about this error, it’s nothing you can resolve on your end. Cloudflare acts as a reverse proxy, and while they have a few standalone hosting options, you appear to be using a traditional web host based on your website’s use of meteor and sockjs.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.