Google cannot index the website

Why google isn’t crawling my site and i also got an email from google saying there is a problem with crawling your website.

When i go and look for an error my Ownership of the domain from google search console as been removed automatically… can someone help me one this

this is something you have to look at on your own.
I will suggest you to remove your site and then re-add it on the console

I did tried by doing this and verifying but am getting an error from Google search console

have you added the TXT record in your DNS which google console has given to you?

1 Like

Yes i have added TXT on the DNS

I would suggest modifing the www TXT record to the value @ (naked domain name) rather than www as far as from the screenshot you are trying to verify a domain name (left side), not the URL like

Thanks am able to verify now… but i have redirection error from google while crawling

Like HTTP to HTTPS or non-www to www, or some other?
Have you got the screenshot of the testing URL?

Hey this is the error which am getting while crawling

Have you tried entering

I assume nowadays the HTTPS should be the one crawled.
Why would you want Google to crawl your non HTTP version?
Nevertheless, if you would have both of them, I think you could end up missing something, eveng the search results could not be accurate, either ranking issues, duplicated content, etc.

Therefore, I see HTTP to HTTPS redirection is working fine for your domain.

Have you checked if some event is shown in Firewall Events tab of Cloudflare dashboard for your domain name?

As I cannot test in my GSC, you should troubleshoot what is among this “fetch error” clicking the button/link therefore.

Okay, let’s try:
**301 Moved Permanently**
**200 OK**

Working fine from HTTP (non-www) to HTTPS (www):


> --------------------------------------------
> 301 Moved Permanently
> --------------------------------------------
Status:	301 Moved Permanently
Code:	301
Date:	Wed, 08 Dec 2021 18:15:01 GMT
Connection:	close
Cache-Control:	max-age=3600
Expires:	Wed, 08 Dec 2021 19:15:01 GMT
Report-To:	{"endpoints":[{"url":"https:\/\/\/report\/v3?s=6vA2t39s7AM0bnaP0wV4jSUl33voeOA7h%2B%2B1hDqQjdeS%2FKZc1Eg%2BbqC2iADYm7ZeQDKvQY4K4RiNc3NIdujxvJigFRvL%2B1V4nYwVVLfX1Rs0x%2BbBPBQqogsQ8rekLoofVuM%3D"}],"group":"cf-nel","max_age":604800}
NEL:	{"success_fraction":0,"report_to":"cf-nel","max_age":604800}
Server:	cloudflare
CF-RAY:	6ba7fa08eb6b6d8f-MUC
alt-svc:	h3=":443"; ma=86400, h3-29=":443"; ma=86400, h3-28=":443"; ma=86400, h3-27=":443"; ma=86400


> --------------------------------------------
> 200 OK
> --------------------------------------------
Status:	200 OK
Code:	200
Date:	Wed, 08 Dec 2021 18:15:01 GMT
Content-Type:	text/html
Connection:	close
strict-transport-security:	max-age=31536000; includeSubDomains
x-xss-protection:	1; mode=block
x-content-type-options:	nosniff
vary:	User-Agent,Accept-Encoding
last-modified:	Mon, 06 Dec 2021 15:47:17 GMT
cache-control:	max-age=0, no-cache, no-store, must-revalidate
expires:	-1
pragma:	no-cache
CF-Cache-Status:	DYNAMIC
Expect-CT:	max-age=604800, report-uri=""
Report-To:	{"endpoints":[{"url":"https:\/\/\/report\/v3?s=E2E%2ByIvkdqx15vKLtj%2BpWx3y%2FqcnBvLdmlIvlmvqS1w1Nuef%2F9%2BXUA%2FCCRILzFETX8vWdNz9DooYDI9MektYY1gaTAZzxpQhruKy7WK0%2BQHEr5flEDnU3yDjKpbDTWR7smE5FHpS"}],"group":"cf-nel","max_age":604800}
NEL:	{"success_fraction":0,"report_to":"cf-nel","max_age":604800}
Server:	cloudflare
CF-RAY:	6ba7fa09a8ba6d73-MUC
alt-svc:	h3=":443"; ma=86400, h3-29=":443"; ma=86400, h3-28=":443"; ma=86400, h3-27=":443"; ma=86400

I see it’s a JS website/web application. Maybe that could be the reason?

If so, I would suggest below articles to check:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.