Google Ad's URL search params being removed from URL

When clicking a Google Ad that links to our website, the URL search parameters (?utm_source=google&gclid=###, etc) are being removed from the URL, even when copy/pasting the URL (including search params) directly into the browser’s address bar.

However, other URL search params are not removed. For instance, literally adding “?gclid=test” to the URL works fine.

Enabling “Development Mode” in Cloudflare DNS temporarily fixes this and allows Google’s URL search params to remain, but once development mode is disabled the issue resumes. This makes me think it is caching-related.

My “Caching Level” is currently set to standard, I have 0 cache rules, not using Argo Tiered Cache or Cache Reserve. My existing page rules are not related to search params at all, & there are no config/transform/redirect/origin rules

I am still experiencing this issue.

I’ve tried disabling all WordPress plugins & any available hosting setting on Kinsta.

The only thing that fixes the issue (temporarily) is enabling Cloudflare DNS’s “Development Mode”, but the issue resumes once development mode is disabled.

I’ve found that, while disabling the plugins does not have any affect, going into the Cloudflare plugin & disabling Automatic Platform Optimization, and then clearing all my hosting/DNS caching seems to stop the issue from happening.

This is not an ideal solution as I would prefer to leave this setting enabled. If anyone knows why this setting is causing this please let me know.

I am still unable to find any permanent solution for this issue.

Have you tried re-enabling APO since you last disabled it a few days ago? There’s a recent update that’s supposed to fix issues with APO that were reported by several users.

I had not re-enabled it recently, but doing it now does look like the issue has been fixed, thank you very much for letting me know.

Do you possibly have a link to anywhere Cloudflare gave information about the update? I’m unable to find any mention of it.

1 Like

I learned about it in topics (such as this) raised by customers, where Cloudflare staff responded after a while to say a fix had been deployed. To the best of my knowledge, a Cloudflare Status issue was never raised.

Awesome, thanks for the info, I appreciate it

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.