Godaddy to Cloudflare Nameserver 404 error

I recently tried to change my nameservers from GoDaddy to Cloudflare.
After 48 hours, Cloudflare never sent me a confirmation email stating that it would, once my nameserver change has completed. I’m still getting a 404 error on my site… (
DNSChecker says my site has propagated, but I still get 404 error …“If this is my bucket. I can change my bucket settings.”
I since then have paused my R2 bucket and disabled my SSL/TLS… but now the error is: ERR_TOO_MANY_REDIRECTS.
What’s worse is that I had previously changed the nameservers before, (and all worked great within a few minutes) but then changed them back to godaddy for support installing a forum and then tried changing NS’s back to Cloudflare. but the site is still not working. I don’t have original DNS records either.
I tried manually changing the A record because I didn’t see any… but it says A record already exists.
Do I have to change the NS back to Godaddy again to get the original DNS records?

I don’t know what to do other than change my NS back to godaddy. Please help

Welcome to the Cloudflare Community. :logodrop:

I recommend against changing nameservers back and forth. It can be quite disruptive and cause unnecessary delays.

Before you do anything else, take stock of all the parts in your setup and figure out how they fit together and how they need to be configured in order to work.

How does your R2 bucket fit into the picture?

Why are you disabling TLS? You never want to disable TLS.

What is your overall goal and what records and settings do you need help with?


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.