GoDaddy Office 365 Set up with Cloudflare

Hi everyone, I feel like I am going in circles. I am setting up office 365 with Godaddy and the instructions are as followed since Cloudflare is my DNS provider:

  1. Log in to your account at the other company.

  2. TXT Record: Find where to add a TXT record, and enter:
    Name TXT Value

@ MS=ms99938843|
@ v=spf1 com -all|

  1. CNAME Records: Find where to add a CNAME record, and enter:
    Host Points to

autodiscover autodiscover.outlook. com
sip com
lyncdiscover com
email email.secureserver. net
msoid clientconfig.microsoftonline-p. net

  1. MX Records: Find where to add an MX record, and enter:
    Host Priority Target

@ 0 com

5: SRV Records: Find where to add an SRV record, and enter:
Port Protocol Name Service Priority Weight Target

443 _tls @ _sip 100 1 com
5061 _tcp @ _sipfederationtls 100 1 com

I have 2 problems:
1) SRV record with _tls protocols cannot be added on Cloudflare
2) I cannot add a 2nd TXT record to add the “@ v=spf1 -all|” as it give me the following error message: DNS Validation Error (Code: 1004)

Can anyone help please?

Thank you very much

PS: I put a space just before the .com or .net of each email as I am only allowed 2 links maximum as a new user.

For your first issue, this looks similar:

As for your second problem, do you currently have an SPF record set? Otherwise the only issue I see if the “|” at the end.

Hi Jake,

I really don’t see how the issue is similar (sorry I am also a noob as the guy who needs helps in the other post).

For the second problem: no I do not have a SPF record, and I just tried without the extra “l” at the end but I still get the same error message.

Have you tried following this

For the SPF are you including the @ in the TXT entry?

I will try the following. As for the TXT it is now solved, I was indeed including the @ in the text entry.

Thank you very much for your help Jake, it is very much appreciated

The Microsoft guide is incorrect.

I dug deep and found this apparently if you use the API you can create the _tls record just not in the web gui


I have same issue, I cant add _tls protocol in Cloudflare now
I have added _tls in other domain since 3 days, seem Cloudflare has been removed _tls, now it only 2 options _tcp _udp

Hello @huynhnguyenthuan0910

It does appear the _tls option was removed in the web GUI from Cloudflare. The current solution is to use the API to create a _tls record.

I would recommend that both of you submit feedback on the new gui saying you need the _tls option back.

Actually for me it worked without adding the SRV record with the _tls protocol. I just tried without it and it worked. Just make sure all your other records are well entered though and you should be fine.

Thanks again for your help Jake :raised_hands:

I found an easier way to add a SRV Record that uses the TLS Protocol rather than using Curl on the command line. I simply exported all the DNS records from my domain using the Export option that appears under the ‘Advanced’ button. I then used the SRV Record using the TCP Protocol as a template to create a new SRV Record with the TLS protocol settings and port. I saved just that single record in a text file and then imported it back to my domain. Easy-peazy, lemon-squeezy.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.