GoDaddy email issue - can't send email only receive

Unable to send emails out (even direct from my GoDaddy host webserver) only receive emails to my mail account. I can also receive emails from my GoDaddy mail server in my email client on my PC. This has been a problem from day 1 of using Cloudflare but I’ve simply used another email to respond to emailers, didn’t have time or inclination to sort this out. So long as I was getting emails. But need to get this sorted now.

Godaddy say have to check with Cloudflare for DNS A records?? Checked DNS record on Cloudflare, has correct shared hosting IP and set mail to DNS only instead of proxy as advised in You Tube video " Troubleshooting Email Delivery Issues"

GoDaddy say have to configure DNS in my control panel yet everything appears correct already. The information they emailed me:

[------- Mandatory Records

A (Host) @ Your account’s IP address (Shared Hosting/Server)

A (Host) mail Your account’s IP address (Shared Hosting/Server)

CNAME www @

MX (Mail Exchanger) @ mail. [your domain name], for example mail.

NOTE: Use MX Priority 0

Warning: You must delete any other MX (Mail Exchanger) entries in the DNS zone file for your email to work. The MX entry listed above should be the only MX entry. --------]

Does anyone have any idea what I need to change (if anything else) in my Cloudflare settings or what information from my Cloudflare settings I need to use to confiure at GoDaddy end? Is there another video out there that might help better.

Many thanks


If it is just your email client that can’t connect then it is likely you have a proxied hostname configured in your settings there. The mail. record should be unproxied (:grey:) and you should specify that for your mail software to connect to rather than the root domain.

Yep, did just that, as suggested in that video. Unproxied the mail entry to DNS only. I should emphasise I am receiving emails fine in my email client and using the web mail client in my Godaddy account directly. But I cannot send emails out. When i do this in my client Thunderbird the sending box just hangs presumably becauise it can’t connect. Thanks for responding though.

There’s often a separate setting in the mail client for the outgoing server, make sure that’s set to the same unproxied hostname. If it is then Cloudflare shouldn’t be affecting anything and I’d recommend checking again with your provider.

1 Like

Thanks but looking at Cloudflare’s DNS record there is no ‘outgoing server’ entry (?) or SMTP port entry for an outgoing server address (as shown in the Mail Client Manual Settings on my GoDaddy account). Just lines for A | mail | IP host server IP address, CNAME | email | and a line for MX | ‘mydomainname’ | mail.mydomainname. With all these set to unproxied made no difference.

So the question is what information will GoDaddy need to help me at their end? Guessing they’ll just point me back to Cloudflare. Because ultimately they would rather I buy into their SSL products. Rather just go without a working reply function :confused:

There isn’t necessarily going to be an outgoing or SMTP record in your DNS assuming you are sending and receiving on the same server. The mail. hostname can be used for both sending and receiving. I’m referring to the settings on your email client having an incoming and outgoing server field, both of which should be the unproxied mail. hostname.

Yes, there is just one server name for both incoming and outgoing. As for my email client settings in Thunderbird on my PC there is no incoming and outgoing server fields just Server Name and User Name and in Rouncube (the only software offered in my GoDaddy host account for email) the Server Settings dialogue box provides no mention of these fields either in fact is even less help than Thunderbird (see below)

Roundcube server settings

To clarify there is no option to add an outgoing port in my Thunderbird email client in settings. The Server Name port number is set for the incoming server. Which is clearly the issue I guess.

My incoming settings are set SSL/TLS as recommended in GoDaddy email config instructions. Found outgoing server (SMTP) field, set to the correct server address and port number for outgoing mail.
Tried changing to SSL/TLS but get “Login to server ---- with username ----- failed.”
So reverted to STARTTLS and changed to no authetication in ‘authentication method’ which prompted “Sending of the message failed. An error occurred while sending mail: Outgoing server (SMTP) error. The server responded: Too many concurrent SMTP connections from this IP address; please try again later.”

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.