Gmail not picking up server emails after change to Cloudfare but webmail working

Hi. I am very new to Cloudfare and have an issue now with sending and receiving emails through Gmail, which usually fetches and sends email from the host server. I am still able to use mail directly through webmail though. I have checked similar threads but couldn’t quite get it. I notice there is an A for webmail but a CNAME for mail in DNS settings. I cannot add an A for mail while a CNAME is there for mail. If someone could lead me in the right direction, that would be wonderful.

I see CNAME mail is pointed to, but may I ask is A :orange: or :grey: (DNS-only)?

Yes, you cannot add A mail as there is already CNAME mail.
To do so and make it work, please follow bellow steps:

  1. Kindly, first remove CNAME mail record
  2. Remove CNAME www record
  3. Add A www record and point it to your server IP, make sure it’s :orange: cloud
  4. Add A mail record and point it to your server IP, make sure this is :grey: (DNS-only)
  5. Re-check and make sure you are using for your incoming and outgoing (POP/IMAP/SMTP) server in your e-mail client (MS Outlook, Mozilla thunderbird, etc.)

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

I would also recommend looking into the below article due to further prevention of your e-mails being marked as a SPAM at the recipient’s side:

Nevertheless, using online tools on the links below you could test and troubleshoot more what is going on with your e-mails:

Furthermore, www.test with :orange: might not going to work as far as you could have the issue with it as written in below article:

Thank you for your very quick response!
A is proxied at the moment.

I will try the list you have suggested, but should I worry about the website working properly or not if I remove the CNAME for www?

That’s the problem. I recommend that you replace that CNAME record “mail” with an “A” record that has the IP address of your entry. And make sure it’s :grey: DNS Only also.

1 Like

Thank you very much for your replies. I removed the CNAME for mail and added an A record with the IP address and I changed the A record to DNS only. However, it still wasn’t working. I had not changed any mail settings and was receiving and sending just fine previously, but noticed in the MX record that the mail server should actually have been just instead of I tried that change and it is working fine now. Not sure why that happened but all seems well. Thank you once again. I really appreciate it.

Your website loads as both ‘www’ and without the ‘www’. Which one is going to be your main (canonical) one?

MX really should point to a ‘mail’ subdomain. Then your can be properly configured as :orange: Proxied.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.