Gmail not loading images

I’m sending emails from a WordPress site that contains product photos. When sending to Gmail users the product photos are broken.

When sending to all other emails there’s no problem.

I deactived cloudflare and now the problem is resolved.

How do I get this to work properly. I want to continue using cloudflare but it’s important that emailed images open on all email providers.

Thank you

May I ask if you have the security Hotlink option enabled at Cloudflare dashboard for your domain? Maybe this could be the reason why.

Moreover, I hope your domain is available to send e-mails and that your WordPress is setup right to use your domain to send out the e-mails? (for example using WP Mail SMTP plugin to setup correctly the way it should be)

And that your DNS A mail record is not being proxied via Cloudflare (should be :grey: cloud), so the Gmail application wouldn’t have the “sender” marked as “not secure” or as a “SPAM” one?

Nevertheless, are you using SPF, DKIM and/or DMARC too? (the DNS record as TXT for your domain)

Regarding Gmail app, as far as I know, each user has the Settings/Options at his mailbox to either block loading of all the external images, or allow and show all of them, or having an option to select “show images for this e-mail message / show images from this sender from now on and apply for future messages from this sender”.

Or, are you serving your images via your host/origin or some other CDN?
If so, is it over HTTPS or you have some mixed-content or redirection loops in between?

When you try to open it up, does it show any error like 404 not found or some other, if maybe access denied?

Were the DNS records from which the images were loaded at the DNS tab/settings page at Cloudflare dashboard proxied via Cloudflare or not? (:grey: vs :orange: cloud)

  • from this statement, I assume you are either using a CNAME record for your mail and that way it was :orange: so there would be an issue regarding it as the IP/sender was not trusted one, rather being a Cloudflare IP address instead of your host/origin …

Thanks for your help. I eventually reactivated cloudflare and now all is well. I guess the problem was the initial activation. I just needed to turn it off and on and now weeks of troubleshooting has now been solved. Cheers!

2 Likes