GMAIL ISSUE! Any help gratefully received!


Hi all,

Could really do with some help here! Moved a domain over to CloudFlare and the gmail associated with this domain stopped working. I have all the correct DNS settings including TXT and MX records (as far as I know) and I have flushed the domain using but nothing seems to work…
Does any one have any ideas? Do I need to make any changes in the back end of Gmail for example? Please help!


@techops1Hi there, I am having the same issue as you describe here. I have tried flushing the domain as you suggest, but it is still not working… do you have any other suggestions? Desperate here!

GMail Delivery failing after switching to CloudFlare

Would you mind posting the domain?



I’ve just posted it for you matteo… thank you


The issue is here:

||300|IN|TXT|"v=spf1 +a +mx +ip4: ~all"|
||300|IN|TXT|"v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAuqRbnarchJcLyahzMBzdm4l8XiBhTBbGI2tx1HylfqwBSNAKtegBlTEs9qJ33EPjrWvfFswmLg+9TQoi4Sk+TofGlZiTBeUpwHQ35g+mkwQuOA1A8BESE9VYqCpQ+i0/jcziMUOvy/JyptQ4iqsdvlYpnl+o4QP0nKHsWDtgbjDtLX6XQr5CFpsuF/lOYGoBD" "\" \"GEU56OoWn8TxPRdMqHvVzaH87hNe1NauXc32u1Drh5qFGZFPXQBf2IZs4PTsKixL0ZnRUFWGxwNDO1mgyzqcMYkfCsV8B/c9AmQ7zdEHWQD59mIyc2JikfLy0CCCTSUhCdoiUx2H3Y6Q2eYyLhcAwIDAQAB;"|

First, the SPF record should have:, second the DKIM is (other than being probably wrong, it shouldn’t contain so many ", check in your Google Admin console here) should be under and not at the root.

The DKIM issue shouldn’t cause direct issues unless it was modified after activating it, since Google didn’t start authenticating emails, but SPF will cause all sorts of problems.


Thank you so much for your help @matteo

when you say “First, the SPF record should have:” do you mean it should look like this…

“ +a +mx +ip4: ~all”

instead of what is there? or how should it look?


Nope, it should be like this:

v=spf1 +ip4: ~all

You do need +mx and +a since you will never send email via those IPs. the other IP I left in there, but check if it is needed.


Great… Ok… I’ve updated that TXT file, but still not working
I can’t check the DKIM as I can’t get into the google console at the moment as it belongs to a client not me, but as you say it should not affect this.

would it help to see my DNS settings in full? I can send a screen shot?


Well, you need to wait for DNS propagation, try waiting a few hours… if you really want to send it please do, note the possible security implications that it would imply. Will have to go in a few minutes, though.


Seen, thanks. It seems fine to me (and checkers online).What exact issue are you seeing? Mail delivery shouldn’t be a problem, except for DNS propagation.

PS: why are you not proxying the www record?


Well, that error is a completely different problem than what could be caused by SPF (this is only outbound, not inbound). This error seems like they didn’t set up an user account for Judith.

Well, you can simply change to :orange: the www record and resolve it via Cloudflare adding caching, security and performance (just like the root one).

Check if the root IP address should be a CNAME, it could be that it as set up with A records at root since few DNS managers handle CNAMEs at root (Cloudflare does).


It’s strange… the email account was working fine and had been for years until I changed the site over and moved to cloudflare… which is annoying. .Ok I’ll take a look at those suggestions… thank you very much for your help @matteo. It is much appreciated. Genuinely. Thank you.


If you discover new info please do let me know.

Wait for DNS propagation to be certain and retry…


Will do… Thank you… (Oh and I just remembered… the www is greyed out as ‘strikingly’ the website hosts stated that this is the setting that needed to be in place. Hopefully that is not causing the email issue! Thanks again.


That wouldn’t be the issue. It seems strange they said so, but oh well. You should still try and reach to check why that would be case.


Inbound mail doesn’t work? When you send a test message from outside do you receive an error?

Your Mx records point to teh Googles

dig mx +short

Your SPF record appears to include the entry for teh Googles for outbound mails.

Nothing appears amiss assuming you use hosted gmail for your mail. Any errors inbound or outbound?


Yeah, I believe his issue is in the Google Admin Console… There were SPF and still are DKIM problems, but those should not cause this kind of issue.

closed #21

This topic was automatically closed after 14 days. New replies are no longer allowed.