Gmail does not accept messages from IPs with missing PTR records


Everything had been working fine before we bought a dedicated IP (on our cPanel shared-hosting package). After that, no email has been sent to Gmail accounts successfully.

When we brought it up with the hosting provider, they said you must disable Cloudflare.
And we’ve tried it many times, and actually, that fixes the problem; as soon as we change the Cloudflare proxy to “DNS only”, the emails will be sent successfully to Gmail accounts.

It’s frustrating, we’ve been digging the internet and found nothing.

Anything that we missed to configure right?

current dns records

May I ask have you tried again? :thinking:

DNS records for A mail and MX are setup correctly.
You also have DKIM selector too:

After you have added it to DNS tab of CF dashboard, have you navigated back to cPanel home, therefore clicked to the “Email Deliverability”? :thinking:

Was PTR there stated by your cPanel hosting provider, or not? :thinking:

You could try by adding a PTR like below example:

I remember, cPanel sometimes doesn’t activate DKIM at all and it’s not a :white_check_mark: until it scans and figures it out on the “external DNS provider” (Cloudflare) that it’s existing one, until them it’s :warning: displayed :thinking:

If it’s recognized and correct, you’d get a blue notification at the top right corner of the cPanel saying that DKIM is enabled and active, therefore on the domain list under the “Email Deliverability” you’d have :white_check_mark: near your domain name.

Maybe some time needed to process this, like 1hour or more for other MTA’s like Gmail.

Hello, thanks for your help,
(the limits on new accounts is the reason i’m sending the message in two separated text).

As i said in my first message, problem will be fixed as soon as i disable CF, here’s the cPanel “Email Deliverability”

and as soon as i enable CF, the problem appears again, here’s the cPanel “Email Deliverability”

Google (and many e-mail services) requires “Forward-confirmed reverse DNS”, i.e. that the IP address associated with the MX record (, in your case matches the domain, but if you reverse-lookup that IP address you get, which is mapped to a Cloudflare address).

If you want this to work, you should have a dedicated IP address for the e-mail server, or disable Cloudflare.


Have you tried setting the PTR to to see if it will use that name in the HELO?

This article from provides more insight into the underlying cPanel issue.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.