GMail Delivery failing after switching to CloudFlare

Our email is hosted by GMail. We just sync’d our DNS server to Cloudflare.

After sync we noticed several staff in our domain were not receiving emails especially the internal emails within the domain. Few folks were getting SMTP errors:

When I run this tool : it reports all sorts of errors but if you check the MX records in Cloudflare DNS they appear to be fine. Is GMail not sync’ing with Cloudflare the MX records? I don’t know why GMail will not work anymore, it was fine before to move to Cloudflare. How do we resolve this?

At our domain host the name servers are pointing to Cloudflare with remote maile xchange setup in the cPanel, so there should be no local exchange.

1 Like

Have you added the Google MX records to your DNS settings?

Yes the MX records in Cloudflare are present:

[[email protected] public_html]# dig -t mx

; <<>> DiG 9.9.4-RedHat-9.9.4-50.el7_3.1 <<>> -t mx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32204
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512

;; ANSWER SECTION: 3599 IN MX 1 3599 IN MX 5 3599 IN MX 5 3599 IN MX 10 3599 IN MX 10

I think I found a solution @!$$% Google public DNS was sitting on cached DNS entries forever ignoring TTL.

Using this tool: we were able to flush our domain records from Google and sure enough it picked up the new MX records and seemed to have solved it. 4 days spent on this. Google sucks.


2 posts were merged into an existing topic: GMAIL ISSUE! Any help gratefully received!