Gitlab SSH Failing / Custom Port / Docker / Linux Self Hosted / Windows SSH Access

I’m coming to the conclusion what I’m trying to do might not be possible, but I have to ask, as the troubleshooting is making me loose my hair, I usually try all kinds of google before I turn to these requests, but these days Google results are either not applicable or don’t make any sense as everybody tried to chime in with their ‘working’ solution.

I’ve a intermediate Linux user, and can usually follow instructions.

So here goes,

I am self hosting my own Gitlab for my own projects, but I was wanting to have a friend work on a project with me. More so I can learn about branching, merging, etc.

I’ve tried setting up the tunnel using the SSH option in the drop downs (when creating the tunnel) but for the life of me, it won’t work.

I’ve tried [sub/domains redacted]

git remote add origin ssh://[email protected]:customport/myuser/myproject.git - Doesn’t work

git remote add origin ssh://[email protected]:customport/myuser/myproject.git - Works

I have various HTTP tunnels setup for various pages on my home network (with application security in front) they all work due to being HTTP.

My SSH attempt, I’ve tried it with and without the custom port on the Cloudflare tunnel, I’ve tried turning off the orange cloud (in case the Cloudflare thing was thinking I was trying to SSH into it) I’ve tried using BASH, I’ve tried a GUI from my Windows machine

Is it an option for the free tier with Cloudflare, or is there a step I’m missing, I really don’t want to be opening the port on my router just for this, if the tunnels can help me.

Can anybody please help me with this.