GitHub Organization Policy is not being saved

When creating an Access Policy for any application (and even the App Launcher), whenever I try to save the settings like:

Include: Everyone
Require: Github Organization (Organization Name: [a valid org name])

The Github Organization part of the policy gets deleted when I come back to edit the Access Policy. And the “error” below is given:

There is an error with one or more of your rules. Reconfigure by selecting an invalid rule and try again.

Are there anyone else having this issue? I’m on Teams Free.

1 Like

Not just you. I’m having the same problem trying to set up AzureAD groups. Also on Teams Free.

Nice find! Totally a :wbug:. Told the development team, they were able to repro and a PR has been made. Should be working as soon as the branch is merged to production (probably hours not days).

2 Likes

Thanks for the swift action! Will try in couple hours.

Uh, is GitHub Auth temporarily blocked until deploy?

Try a hard refresh or logout and log back in? At the moment it works for me… well… the screen has fields anyway.

1 Like

Now it shows up, I don’t know what happened buut yeah.

Okay appearently if you leave the GitHub Team field empty, it doesn’t save properly.

And the org I’m trying to configure doesn’t have teams :stuck_out_tongue:

@cscharff Well after couple hours I tried again and it still seems to be broken.

You can save it properly if you also add a team to the rule but that’s not I want. And in fact, that also creates the quoted error on the first post, just that it stays on and the rule works.

It’s coming up to 3:30am in Turkey and honestly I am really tired to find what was causing the problems, tldr below.

So to pass a rule with no Teams on App Launcher, I had to make a breakpoint on //src/pages/access/authentication/appLauncher/AppLauncherConfig.tsx:81 and make a rule with a team name of *, modify the config to have teams as an empty string.

For Access Policy Rule in Apps, I had to make a breakpoint on //src/pages/access/apps/AccessPolicyRulesTab.tsx:104 and do almost the same for App Launcher.

TL;DR: The client side code has a broken verification code where possibly any empty vallue is not passed on, I had to modify my requests that had invalid GitHub Team names with empty strings and that worked.

@cscharff I really didn’t have to glance over the source map of the frontend on Chrome DevTools and look at what’s wrong but honestly I want to test your products and this kept me so annoyed that I had to.

Final update: Looks like the fix has been deployed properly.