Git time out when pushing repository (worked before Cloudflare)


#1

Hey guys,

I’ve just installed Cloudflare’s DNS to my site. Since then, I can’t seem to push my dokku repository to the server anymore cause I get a time out.

ssh: connect to host mydomain.com port 22: Operation timed out
fatal: could not read from remote repository

Please make sure you have the correct access rights and the repository exists.

We have a staging server without Cloudflare, and it still works there. What can I do to solve this? I couldn’t find anything on Google and in Cloudflare’s documentation about it.


#2

You seem to connect to an SSH server which is most likely proxied through Cloudflare. That wouldnt work. You’d need to connect to the IP directly or unproxy the host (switch to :grey:).


#3

Ah, I tried to switch off the orange cloud (unproxy the host) yesterday and it didn’t work, but I guess I was too fast in trying, so it hadn’t propagated yet.

Worked now. Thanks for the fast help, Sandro.