Getting "This service has been suspended by its owner." error again

I’ve just tried using Cloudflare in front of a website ( https://ooh.directory ) but am seeing this error message in the browser:

This service has been suspended by its owner.

Before I added Cloudflare the site was working fine, using a Let’s Encrypt certificate.

I added the site in Cloudflare, changed the domain’s nameservers to Cloudflare’s, and set these settings in Cloudflare:

  • Set “Automatic HTTPS Rewrites” to on
  • Set “Always Use HTTPS” to on
  • Set “Auto Minify” to on for JS, CSS and HTML
  • Set “Brotli” to on

But now I get this error. What am I missing?

(I had an identical error a few days ago, asked about here which I assumed was some mistake I’d made with getting rid of the Let’s Encrypt certificate and generating Cloudflare Origin CA certificate. I’ve avoided that this time, and kept it simple, and yet…)

What happens when you pause Cloudflare?

The error goes away and I can access the site.

Did you use this domain name with a service that may have used Cloudflare for SaaS? If you did, it may be that your domain was not removed from their account. The following tutorial explains in more detail. If that is the underlying cause, you can use the Community tool, Liberate The Hostname, to fix this yourself.

I’ve never heard of or used Cloudflare for SaaS I’m afraid.

The time I got the error message a few days ago was the first time I’ve ever tried to set up Cloudflare for this (or any) domain. The domain has only ever been used for this one website, and never had a CDN of any kind on it until now.

You wouldn’t likely be aware of Cloudflare for SaaS. It would have been used behind the scenes at a service provider like Shopify or ClickFunnels.

I’d use the tool just to be sure

Falling at the first hurdle… the tool wants me to add a CNAME record for my domain, but obviously there’s already an A record for my domain, and the Cloudflare interface pops up an error:

An A, AAAA, or CNAME record with that host already exists. (Code: 81053)

Make note of the IP address in it and then delete the A record. Add the requested CNAME. Once you have finished, delete the CNAME and restore the previous A record.

I take it all back! I used the tool and – after a while of the DNS re-propagating – the site works, with Cloudflare!

I don’t understand why that happened. As far as I can tell no one had this domain before me (although obviously I can’t be entirely sure) and the first time I used it since registering was pointing it at this VPS a few months ago.

Thank you for your help and patience.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.