Getting "Pending Nameserver Update" Message

It has been a couple of days now and I still get the “Pending Nameserver Update” message. I’ve changed the DNS settings for both the original domain holder and also for Cloudflare. Not sure what to do? Thank you in advance for any assistance. (I’ve already contacted support, which directed me to ask the Community.)

1 Like

I am afraid you have not. It still points to the original nameservers.

Also, your server does not have a valid SSL certificate. You need to fix this first before using Cloudflare.

Thanks for your reply. I’m afraid I don’t know how to do any of that. I’ve been reading the articles and changing options, but it seems like I’m just going in circles…

All right, for starters you should fix the SSL issue on your server. Make sure your site loads fine on HTTPS before doing anything with Cloudflare. If you are unsure how to do this contact your host.

I got my domain through Shopify. That is the host then, correct?

Presumably, the host is where your site is hosted.

Okay, that’d be pixels.com. I’m pretty sure they support https, as their instructions indicate to use the HTTPS Always ON option.

Your site currently does not load on HTTPS. Maybe you need to change something on their end, but that’s something you need to fix first.

This is so incredibly frustrating. Thanks for trying to help.

Sure, these things often have a steep learning curve, but that’s also where your host is supposed to help you. Once your site loads fine on HTTPS you can look into Cloudflare again.

Okay, I’ll contact the host again and let them know about my site not loading on https. :blush: :+1:

Should they want to charge your for an SSL certificate, politely point out that Lets Encrypt offers them for free and you can even get an Origin certificate from Cloudflare to install on your server.

I did try creating a certificate through Cloudflare, but it wouldn’t allow me to.

Could you upload this to your host in the first place?

Honestly, I’m not sure… I emailed pixel a few minutes ago and they have surprisingly emailed back already, so hopefully they’ll be able to shed some light on the problems I’m having.

An Origin certificate you can get from https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/origin but IIRC your domain first needs to be active on Cloudflare.

But you need to first clarify with your host how to configure that on your server. Maybe they don’t allow a third party certificate and configure everything on their own.

Their response was that they’ve never had compatibility issues. They asked for some images of my DNS settings, which I just sent.

I am afraid we are bit beyond the scope of the forum at this point as this is not Cloudflare related any more.

But once your site properly works on https://rmooreart.com you can set it up on Cloudflare.

Thank you; I really appreciate your input.

Although fixing SSL on your origin (aka your hosting provider’s server) is a good thing - it’s not essential for using Cloudflare. If you have issues with SSL once Cloudflare is activated, it can be addressed at that point.

The key thing stopping you from activating Cloudflare is that your NameServers are not set to Cloudflare’s - we can check this using whois:

🚨 $ whois rmooreart.com | grep "Name Server"
   Name Server: NS-CLOUD-E1.GOOGLEDOMAINS.COM
   Name Server: NS-CLOUD-E2.GOOGLEDOMAINS.COM
   Name Server: NS-CLOUD-E3.GOOGLEDOMAINS.COM
   Name Server: NS-CLOUD-E4.GOOGLEDOMAINS.COM

You can also check via a website instead of using the whois command - for example: https://whois.domaintools.com/rmooreart.com

To change the nameservers, you need to log in to your domain registrar (where you purchased your rmooreart.com domain - it looks like Tucows) and remove those googledomains.com name servers and replace with the two listed in your DNS screen on Cloudflare:

aldo.ns.cloudflare.com
alexa.ns.cloudflare.com

Once that’s done, Cloudflare should activate.