Getting net::ERR_CERT_AUTHORITY_INVALID using self-signed SSL Certificate

Answer these questions to help the Community help you get started.

What is the domain name?
saddleworthwi.com. I’m migrating the site. It works fine on the old server. It is currently set to old server IP. I briefly switch to the new server IP to test.

Have you searched for an answer?
Yes

Please share your search results url:
https://www.google.com/search?q=cloudflare+ssl+full+not+working+with+self-signed+cert&rlz=1C5CHFA_enGB1060GB1061&oq=Cloudf&gs_lcrp=EgZjaHJvbWUqBggBEEUYOzIGCAAQRRg8MgYIARBFGDsyBggCEEUYOzIGCAMQRRg5MgYIBBBFGDwyBggFEEUYPDIGCAYQRRg8MgYIBxBFGDzSAQg2ODIwajBqN6gCALACAA&sourceid=chrome&ie=UTF-8

When you tested your domain, what were the results?
net::ERR_CERT_AUTHORITY_INVALID for all resources. It’s a WordPress site.

Describe the issue you are having:
net::ERR_CERT_AUTHORITY_INVALID for all resources. It’s a WordPress site.

What error message or number are you receiving?
net::ERR_CERT_AUTHORITY_INVALID for all resources. It’s a WordPress site.

What steps have you taken to resolve the issue?

  1. Tried using the certificate that works on the old-server

Was the site working with SSL prior to adding it to Cloudflare?
NA

What are the steps to reproduce the error:

  1. Switch the DNS IP on Cloudflare dashboard

Have you tried from another browser and/or incognito mode?
Yes

That is the important bit. Your site needs to be secure before you use Cloudflare.

Right now it is still without encryption and you need to talk to your host to get this fixed.

Yes it was working with SSL on the old server. It has been on Cloudflare for around two years. I am migrating it to a new server. On the new server I created a self-signed certificate and used the Cloudflare SSL option Full which says is suitable for a self-signed certificate.

I am afraid a self-signed certificate cannot secure that and Full should not be used either.

Switch that to Full Strict and deploy a proper certificate (an Origin certificate would also work) and it will work fine.

Steps to take

  1. Pause Cloudflare - Pause Cloudflare · Cloudflare Fundamentals docs
  2. Switch to Full Strict
  3. Make all necessary changes to your server to make sure the site loads fine on HTTPS
  4. Once the site loads fine on HTTPS, you can unpause Cloudflare and it will work

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.