Getting many 503 errors on the website


#1

Hi there, I am using cache plugin “WP rocket” + Cloudflare.
When I activate Cloudflare, I am getting many errors due to not loaded images. These are the images of the woocomerce products mostly the feedbacks. Some are loaded and some are not.

The website: https://www.badetonneholz.de/

I am really struggling here and can’t find the issue.

These errors look like this: http://prntscr.com/mlp62w

Thanks for your help.


#2

Also, forgot to mention that those errors are gone once I pause the Cloudflare.
And also very strange that if you reload the page those images appear.


#3

Just tried accessing your site via Cloudflare and the images loaded

Do you experience the issue only in edit mode or also as regular visitor?


#4

Hello,

Thanks for getting back. As you verify the website I was already reverted to my original server dns due to clients complaints.

I just turned on cloudflare on not so heavy used website to make some test.
The website: https://www.baliaogrodowa.pl/

Error in console: http://prntscr.com/mm5v1m
Error in server log: http://prntscr.com/mm5v4b

If reverted to original server`s DNS, those errors are gone.

I would be very thankful for your help.


#5

Please read my response and pay attention to the screenshot.

I intermittently get 503s but these come straight from your server.

image

This is also shown by the server log. You need to fix that over there and possibly increase the respective value.


#6

Yes, that is the problem. Our server provider gives the maximum of 64 connections at the same time and I can’t increase this number.
But if the website is running on the original server DNS example: https://www.badetonneholz.de/ the error is not there anymore.

I just don’t know where to start, tried disabling all caching plugins etc… but once I enter cloudflare DNS, there errors appear.


#7

These errors appear to be very intermittent and as you can see from the earlier screenshot do not necessarily happen in a Cloudflare context either.

My guess would be it comes down to how many concurrent requests are sent to the server. With 256 being the default it would appear as if 64 is somewhat of a small number for this setting. I’d contact the host and try to have that number increased. If that does not work I’d consider switching to another host. Alternatively, you can also try to reduce the number of overall requests to your site by having less embedded resources.


closed #8

This topic was automatically closed after 30 days. New replies are no longer allowed.