Getting http 400 trying to access CF Tunnel Public Hostname

Hello team,
I am trying to access my self-hosted services leveraging CF Tunnels. I successfully set one up and I can see it in the dashboard.
Though, when I am trying to reach my service with the public hostname ha.ivanpiazza.com I get HTTP 400 error.

I am using docker-compose. In the yaml file I defined the network tunnel and then I assigned it to all the services I want to expose. Each service has its container_name string in order to be resolved when called by any other service in the tunnel network.
Then I created the public hostname in the CF dashboard.

From the CF-tunnel container log file I can see the below:
2022-10-27T17:23:14Z INF Updated to new configuration config=“{"warp-routing":{"enabled":false},"ingress":[{"hostname":"ha.ivanpiazza.com","originRequest":{},"service":"http://###########"},{"service":"http_status:404"}]}” version=4

I created a dummy service, set the tunnel network to it and nc -v ####### #### and it states the port is open by referring to the container_name of the service I defined in the public hostname.

Can anybody help me out understanding where the issue is?

Thanks very much,
Ivan

I found the solution in the home-assistant community: add the tunnel network cidr to the trusted proxy directive.

Link down below.

https://community.home-assistant.io/t/home-assistant-access-via-a-cloudflare-tunnel/443044