Getting "Fastly error: unknown domain" with CNAME to tile.openstreetmap.org

Hi all,
this is my first post in the Cloudflare community.

I have added a DNS CNAME entry for the domain static-assets.net to be able to cache the tiles from openstreetmap.org in this way:

|CNAME|tiles|tile.openstreetmap.org|Auto|Proxied|

The original URL returns the tile as expected: https://tile.openstreetmap.org/4/0/4.png
If I visit the proxied one (https://tiles.static-assets.net/4/0/4.png), in the response I’m getting a 500 error:

Fastly error: unknown domain: tiles.static-assets.net. Please check that this domain has been added to a service.

Details: cache-fra19145-FRA

I don’t know if the issue is with Cloudflare, I have other CNAME entries to other domains that are working fine.
It would be great if I could solve this problem in some way or have some useful tip in the right direction.
Thank you for your support!

1 Like

You can’t CNAME to an unwilling host. If you want to CNAME to someone, they have to configure their server to recognize your hostname. It does not seem like you have made this arrangement with them.

OK, thank you for the fast reply.

My goal is to use my domain to cache the tiles from the openstreetmap server, is there any other solution to do this with Cloudflare?
I had a working solution using my custom domain to get the tiles before, I don’t know why it doesn’t work anymore (I don’t remember if I’ve changed the DNS settings or the openstreetmap server changed something on their side to reject the request).
Thank you