Getting error trying to enable cloudflare


#1

My domain rctngl.xyz is using cloudflare in DNS mode. However I was trying to enable the Performance Optimisation which is giving me the error as mentioned in screenshot above. Please help.


#2

#3

Cloooooooooooooooooooooooonan! :wink:

@cloonan


#4

If this is the bug I think it is, you can work around it by changing the cloud to :grey:, then edit the record again and change the TTL to anything in the list and then back to automatic, and finally change the cloud to :orange: again.

It seems to happen when you import a zonefile, Cloudflare’s zonefile interpretter is most charitably described as quite poor.


#5

That I have never tried but the issue is Cloudflare sends a string when it should an integer and that only happens on the mobile view. Is that the same issue you were referring to? I’d be surprised if the proxy status had an effect here, but who knows :slight_smile:

Also, one thing to keep in mind, switching temporarily to :grey: does potentially reveal the origin.


#6

The problem is that the record was originally created with :grey: and I wanted to enable :orange: however, I’m away from laptop for some time so tried doing it from mobile and hence the above issue.


#7

Just switch to desktop mode in your mobile browser and it should hopefully load the desktop page, where you can make that change.


#8

That worked, thank you :slight_smile:

It’d be nice if the issue is fixed for mobile version too.


#9

Absolutely, hence the battle cry for Mr. @cloonan earlier :smile: