Getting Error 525 SSL handshake failed please help

I have configured my website with Cloudflare but I am getting the error 525 on enabling SSL full(strict). Let’s Encrypt SSL is installed by my hosting company. I contacted them to check if they have configured everything properly and this is what they said:
"Yes. Everything is configured correctly and the ports are also enabled. However, since the SSL is installed through Cloudflare, you will have to check with them. Once you disable Cloudflare and A record of the domain is pointing to our server, the SSL will be working fine within few hours.

If you enable Cloudflare, you will have to use SSL that is installed at their end since the A record of the domain will be changed. However, you can check with Cloudflare and see if the A record of the domain can be pointing to IP: by disabling CDN"

Please help!

And did you check that?

You have some mixed content issue on your site (which is a different issue) but the SSL configuration seems to be all right, hence I would assume your DNS records on Cloudflare are not proper.

I have disabled Cloudflare and A record still points to Cloudflare. May be I will have to wait for sometime.

Your problem simply is that your DNS records are not correct (as your host suggested). You need to take the steps your host already mentioned and check (and fix) these records.

I disabled Cloudflare and tried adding A record as mentioned in this page :
And I got DNS validation error
May be what I was dong is wrong. Can you please tell me step by step how this is done.

Remove the “www” CNAME pointing to, then remove the two A records pointing to and

Eventually create two A records (“www” and “@”) which you point to

Thank a million!!! It worked!!

This topic was automatically closed after 31 days. New replies are no longer allowed.