Getting Error 1020 on all BitcoinSV blockbook explorer instances. Why is this happening?

What is the domain name?

Have you searched for an answer?
Yes, nothing particular relevant to to my problem.

Describe the issue you are having:
Cannot access BitcoincashSV blockbook explorer without getting Error 1020. Especially when trying to access api endpoint ‘/api/v2/xpub/*’.

What error message or number are you receiving?
Error-1020

What steps have you taken to resolve the issue?
Couldn’t resolve it, that’s why I’m posting and asking here.

Was the site working with SSL prior to adding it to Cloudflare?
Not relevant

What are the steps to reproduce the error:
Use any of the listed domains from above.
Try to access the api endpoint ‘/api/v2/xpub/’.
That is enough to reproduce and show the error. See attached screenshots.

This is particularly odd because this is happening to all bitcoinsv blockbook explorers that I was able to find and they all return error 1020 in some form even though different companies and entities are hosting them. This suggest to me that this isn’t just some one-off incident of a domain host banning access to it.

What’s also odd is if the xpub address is omitted, I do get json response “{error:Missing xpub}” which is what I expect but the moment a valid xpub parameter is included in the request, error 1020 happens instead of a json response.

Also important to note, this does not happen to any other coins that have blockbook explorer/indexer support; it’s only happening to BitcoinSV. For example, dogecoin, dash, litecoin they all work as they should even from the same blockbook providers that’s having issues with bitcoinsv.

Have you tried from another browser and/or incognito mode?
Yes, even from a different ip, vpn, all result in the same error code.

Please attach a screenshot of the error:

Quick question how am I suppose to include the problematic domains in my question if Cloudflare won’t let me include links? I can’t even list the problematic domains because Cloudflare interprets them as link and won’t let me post it.

Just to add more context, the other blockbook explorers I’ve tried are:

  • bsvbook.guarda dot co
  • bitcoinsv.atomicwallet dot io
  • bchsvexplorer dot com
  • bsv.nownodes dot io

I see you successfully used the ‘dot’ method. Another way is to enclose the domain name in backticks ` so that they presented as code blocks. You can create multi-line code blocks by placing only three backticks on the line above and the line below your text.

1 Like

May I ask if this is your domain which you own and have control over, or not? :thinking:

That’s good to know, will keep it in mind for future.

1 Like

No I do not have control over those domains. They’re operated by different companies in the blockchain space. Guarda, atomicwallet, nownodes respectively.

They all exhibit the 1020 error. I suppose it’s possible they all banned access but that seems unlikely to me. Especially considering I haven’t really used at least one of them nownodes, so why would they even institute a ban?

An analogy would be like troubleshooting piece of PC hardware, you think there’s something wrong with GPU but then you go ahead and try 3 other video cards and they fail to POST with a display. Is it possible all 3 cards are bork? Sure. But is it likely? Probably not.

A 1020 is explicitly a firewall rule created by a customer - Cloudflare’s Managed Rules show a different page.

The only way to know what caused it though is to give the Ray ID to the site owner and let them check the event log in the dashboard for it.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.