Getting ERR_TOO_MANY_REDIRECTS when the connection is proxied

I have several domains on free plan. Totally 8. All are configured with the similar settings. 6 of them are accessible when proxied. 2 of them are not accessible when proxied with the ERR_TOO_MANY_REDIRECTS error in the browser.

Here are the settings I used for one of this problematic domains:

Here the proxy is switched off and the site is accessible from the Internet: Screenshot by Lightshot

Here the proxy is switched on and the site is NOT accessible from the Internet: Screenshot by Lightshot

The Cloudflare test returned to many errors: Diagnostic Center | Check SSL and Test Website Security | Cloudflare

This is not the first time when I have this type of problems. Previous time I solved the problem may be 14 days ago by deleting and resubmitting the other domain to Cloudflare. I tried to resubmit in the same way also now but has not get any effect. This site and one more ( are not accessible when proxied.

Here is one site which accessible when proxied from the same server and with the similar settings on Cloudflare:

Please, advise. May be this is the time for me to reject Cloudflare. Or not?

Switch your encryption mode to Full Strict.

1 Like

Switch your encryption mode to Full Strict .

Can you provide the screenshot for this setting, please?

I found that I should switch off http to https for domain redirect on my original server.

  1. Remove the HTTPS redirects in your origin server.
    Community Tip - Fixing ERR TOO MANY REDIRECTS

I will try this now. But the problem is that other domains are configured on the original server in the similar way: with http to https redirect. And they are working.

Leave the redirect on your server. Just switch the encryption mode.

I am confused. Where should I apply this setting exactly? Is there any screenshot?

That did not tell you where to find it?

No, sir. I am new here on Cloudflare. Is this possible someone else provide me the screenshot for


That’s interesting. The first thread actually already not only has the screenshot you asked for, but even the exact link.

Seams that you are making some business of proudness here.

Seems you are not making the least effort :wink:

Can you, please, avoid my theme and provide no more answers?

Well, the answer is already in the first response. Plus I told you how to do it, if you opt not to even click a single link, then nobody can help you.

Finally the solution is that you should go to the SSL and choose Full (strict). It is strange that Cloudflare does not ask for the setting when you are adding domain making all this confusion possible.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.