Getting blacklisting issues with Clean Talk - and they say:

It seems that you are incorrectly transferring HTTP headers.

A real visitor IP address should be contained in the cf-connecting-ip header.

All of the requests we see on your site have Cloudflare’s own IP in cf-connecting-ip header and real visitor IP in X-Forwarded-For header. It is incorrect and calls false positives from CleanTalk.

  • How do I do this? They gave me these articles, which confuse me further as I am not seeing anything wrong:

May I ask with which CMS are you using CleanTalk?

Moreover, the mentionet articles from above have instructions as needed to make sure you see the real IP of a visitor to your website in your log files, otherwise always would appear only Cloudflare’s IP address.

You would need to access your hosting provider interface and depending on the web server, you would need to apply changes. It requires some knowledge.

If you can, ask your hosting provider to give you a feedback information if they can implement the needed because you would like to use Cloudflare service for your domain.

Other possible solutions, from my point of view, you could either try to learn some basic stuff related to your web server type - which could depend because maybe you do not have an access or privileges to changes the needed stuff or modify them, - or, have a captcha at your comment section, or if using WordPress then try with plugin Akismet and some other security plugins like WordFence (it has got implemented option to select CF-Connecting-IP).

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.