Getting an error "undefined ", in the footer of my website, after registering a domain name from Cloudflare

Getting an error "undefined ", in the footer of my website, after registering a domain name from Cloudflare.

Do you have any evidence that it’s Cloudflare adding this? If you grey-cloud the DNS entry, does the “undefined” go away? If it persists when grey-clouded then it has nothing to do with Cloudflare. Have you tried opening a HTML file on your server in a text editoring and deleting the <div>undefined</div>?


I have other domain names that I registered from other providers, they work well, but the one that I registered from Cloudflare doesn’t work well, as mentioned above.

Does the issue persist if you pause Cloudflare? You can do so on the overview page in the dashboard.

1 Like

I have paused Cloudflare but the error is still there.

So Cloudflare is not responsible… you’ll need to open the HTML file in a text editor and remove the div

it doesn’t exist, just when I connected my website to the Cloudflare domain name that I have registered the error appeared, the problem comes from Cloudflare but I still don’t know how and where…

First of all it’s not an “error” it’s part of your own HTML. If you paused Cloudflare then traffic is routing directly to your origin server and responses are coming directly from your origin server. Therefore it’s literally impossible for Cloudflare to be making any changes to the page.

Did you build the website yourself? Did you use some kind of site builder or framework? Is it a static website or dynamically generated? Do you have shell access to your web server? Have you logged into your web server, located the index.html (or whatever it’s called), and looked at it in a text editor?

I tried other domain names from other providers, everything worked well, even I change my website and used the domain name on another website, the same problem appears, I told u an error because I checked my code and there is no problem with that, the div "undefined " just when I connect my website to a domain name I bought from Cloudflare.

Thank you a lot because you tried to help, I found the problem where comes from, it is from Cloudflare “zaraz”, after deleting tools I added on Cloudflare zaraz, the error disappeared