Getting a "this connection is not private" and "not secure" error

My domain is and it says my edge certificate is active.
Tried setting my SSL/TLS encryption mode to Full (strict) with no luck. Page does not load or show content, just the error that it is not secure. How do i fix this?
Home page is

Your DNS records are not proxied (set to DNS only), so traffic is not passing through Cloudflare and is going direct to your origin.

The certificate on your origin is self-signed (hence your current problem) and will also give an error when proxied through Cloudflare and using Full (strict). Consider using a CA certificate (such as LetsEncrypt) or the Cloudflare origin certificate.

1 Like

I switched my SSL to flexible mode and now the page loads but it comes up as “not secure” how do i fix this?

Your DNS records are still not proxied. Making changes to your Cloudflare settings will have no effect until you enable the proxy as requests go direct to your origin.

Go here…

Edit the records for @ and www and press the switch labelled “Proxy status” so it goes orange and then you will see the grey cloud go orange in the DNS to indicate traffic is passing through Cloudflare.

Then… Flexible mode shouldn’t be used as it make the Cloudflare proxy connect to your origin over HTTP, and even if your users see HTTPS to Cloudflare, their data is not encrypted to your origin.

You should fix your origin certificate and then set SSL/TLS to Full (strict).

I am working through Go High Level and it has to be through DNS or it cannot communicate through the site. (this is what my mentor has told me)

If you have to use “DNS only”, then Cloudflare can’t do the SSL for you. Just fix your origin certificate to solve your problem.

1 Like

Fix the orgin certifricate to what?
Will that make the website secure? Do I go through LetsEncrypt?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.