Getting a 503 Response only from Cloudflare Servers

I am trying to make a request to the Apple Music API via my cloudflare server.

It is essentially an authenticated request for example to:
https://api.music.apple.com/v1/catalog/us/search?term=caldonia&types=songs

For some reason Apple is returning a 503 only to Cloudflare servers. From other servers it works fine. Any idea why this might be? I’ve tried pausing Cloudflare and still no luck. I have no idea how to troubleshoot it. Suggestions on what to try would be much appreciated.

Thanks!

Check the payload of the error response, which should contain an errors array with more details.

What do you mean by:

via my cloudflare server

Is this a worker, or just a request being made from an application on a server which is proxied by Cloudflare? If the latter, this is entirely unrelated to Cloudflare. The request will be made directly from your server to Apple, and nothing in Cloudflare will be involved.

Thanks for the response Michael.

So this is indeed an http request being made from an application on a server which uses Cloudflare as a CDN and WAF (I guess “proxied”?). Not sure why, but we have noticed that this issue happens only when we make the request from servers that “use” Cloudflare and not from other servers.

Someone even posted about it on the Apple Developer forum but not much engagement there:
https://forums.developer.apple.com/thread/124314

It’s a tough problem, bc I figure even if Apple responded they would say that their API works fine and so this must be some issue with our side (either our server itself or Cloudflare). Since we have tried multiple servers from different providers, the only common denominator is Cloudflare (I have the same problem making the request from two different servers from two different providers that both use Cloudflare and when I try the request from a server that doesnt use Cloudflare then it works fine).

Again appreciate your help troubleshooting!

This topic was automatically closed after 14 days. New replies are no longer allowed.