Getting 522


I am getting 522 for one of application.

Here is the setup I am using.
DNS is transfer from Namecheap to Cloudflare.

The main application with domain is hosted at Namecheap which is working perfectly.

I create a subdomain and host another application to another server. This server has h/w firewall configuration that only allow the https request from Cloudflare IPs. I upload the SSL at Plesk at origin server for this subdomain. But didn’t add this SSL at Cloudflare (not sure it required or not).

The connection from Cloudflare to Origin Server is using port 443 if I don’t upload custom SSL?

I have another application that is hosted on same origin server. It is working fine. The difference is this application hosted with different sub domain of different domain and has custom SSL uploaded at Cloudflare.

Could anyone tell me the possible reason?

Solve the problem. forgot to end full encryption option.

Full is unfortunately not secure. Make sure it is Full Strict, otherwise you have no proper encryption and validation.

Hi sandro,

Could you please suggest the cost effective way of doing it? I purchased the SSL globalsign, but if I want to upload it on Cloudflare, I need to upgrade to Business Plan.

If I purchase it from Cloudflare. It will work for Full (Strict).

You don’t need a paid certificate. Switching to Full Strict is enough.

Should you need a server certificate (which would be a different issue), then you can take a look at Origin CA certificates · Cloudflare SSL/TLS docs

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.