Getting 521 error sometimes and then resolves itself after few mins

My website https://gshunzadryfruits.com is getting 521 errors lately. I get the error for some time and then after few minutes, it resolves by itself. My site is hosted on Godaddy Managed WordPress hosting. After reading some articles here in this forum I contacted the support to see if Cloudflare IPs are blocked by the server, but they aren’t.
I checked with KeyCDN’s HTTP checker it also shows the server is working(if that what it checks, not sure about this)

I’ve sucuri enabled on my site, I don’t know if that is causing any issues.

During 521 error, my uptime monitor doesn’t show the website as down.

I’ve check all the tips on this page. Community Tip - Fixing Error 521: Web server is down

I see many errors in Chrome console related to your cached static assets, try to rebuild your cache by your caching plugin or resolve all errors with it. Basically, i’ve seen my chrome request many files may not exits on your server.

1 Like

Cleared cache from WP Rocket as well as Cloudflare. Where exactly can I check those errors?

In Chrome, press Ctrl + Shift + I, reload your page without cache and check for errors in Console & Network tabs. Click on resources was marked in red color to find out what’s cause the errors or prevent it to load! Your case seem you moved your site from old host to GD

Yes when my hosting plan was due for renewal, I bought a new plan and cloned my host there. I didn’t notice any differences or issues till now.

Your website is working fine at my last reply on my browsers, but now, some resources hit 521, i think your host prevent Cloudflare to get that, may be rate limiting or something else.

I contacted the Godaddy team and according to them, Cloudflare isn’t blocked or there is no rate limiting.

That’s the issue, sometimes there is a 521 error and then it resolves by itself.

@MoreHelp Please any help regarding this? I’d enabled debug mode, I can provide that log too.

May I ask have you followed below article to correctly setup the WP Rocket and Cloudflare?:

Do you have an valid SSL certificate at your origin/host for your domain and your sub-domains? Also, which SSL mode have you got enabled (Full SSL, …)?
Did you have had an SSL certificate before moving your domain/website to Cloudflare?

Kindly, check the steps from below article to make sure you have the right SSL setup:

Are you sure you do not have some mixed content errors or redirect loops regarding the resource loading issue?

Have you tried purging cache at Cloudflare?

Maybe the Cloudflare somehow loses the connection to the origin host/server?

How about visiting https://yourdomain.com/cdn-cgi/trace/ and posting your output here?

Have you tried writing a ticket and contacting Cloudflare support due to your domain issue?

1 Like

Yes have done that, and checked again now.

Its flexible ssl, should I change it to full?

Right steps are done for flexible ssl.

I’m not sure about that, how can I check that?

Yes several times.

fl=20f435
h=gshunzadryfruits.com
ip=118.107.143.252
ts=1622649896.476
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0
colo=AMS
http=http/3
loc=PK
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off

Plus I see this error on GoDaddy, which apparently can not be fixed if the A records are set to Orange.

image

Unfortunately this one has a great potential to create issues just like mixed content, etc.
More, described here:

It should be **Full (Strict) SSL **.

If you do not have your own SSL certificate that covers both main domain and www, and also other sub-domains too if needed, in that case I recommend you to go with Cloudflare Origin CA certificate and put the SSL mode to Full (Strict) SSL at Cloudflare dashboard:

Here are the articles:

1 Like

I believe you can ignore the DNS warning from GoDaddy due to using Cloudflare, and as long as your domain DNS records are pointed to the correct IP address at GoDaddy, while being :orange: cloud (proxied via Cloudflare), it’s all good as it should be :slight_smile:

1 Like

For a Full Strict SSL, I’ll have to install a certificate on the server-side, which isn’t possible on GoDaddy Managed WordPress hosting (According to the support team), so that’s not an option

I don’t think there are any mixed content errors, when there is no 521 error, the website load perfectly with a green padlock. I’d SSL enabled from the beginning of the site about 2 years. I recently changed hosting(cloned site) I don’t know if that made a problem.

Of course, but a certificate simply is a requirement for SSL. If your host does not understand that it is best to switch to one who can offer such a basic hosting feature.

I don’t think any managed WordPress hosting offers this functionality, for example, Namecheap’s EasyWP doesn’t even work with cloudflare.

I am afraid that is not true.

image

1 Like

I have an active hosting on EasyWP, the Free PositiveSSL is for domains you have on Namecheap (at least DNS with Namecheap) so no use with Cloudflare. Plus EasWP doesn’t give you an IP to connect, they give you a CNAME URL, which is even worse! You can’t enable proxy on cname (because it EasyWP won’t accept that) so all the features of Cloudflare are useless with EasyWP.

Comes with SSL too

image

But as I said

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.