Getting 520 Error when I edit a large post. Service provider said ask cloudflare team

I am facing a 520-page error. I talked to the service providers. Here, in my case, My WHSP is Godaddy. The team cleared me that for their end everything is fine. Also, They told me it’s an issue with DNS so visit and ask Cloudflare.

I came here and, observed some errors in the DNS setting on the site’s dashboard of Cloudflare.
It was written “Some of your DNS-only records are exposing IPs that are proxied through Cloudflare. Make sure to proxy all A, AAAA, and CNAME records pointing to proxied records to avoid exposing your origin IP”

I don’t know How and What to fix now? Because For obtaining awesome services of Cloudflare purpose, I changed nameservers earlier on my Cpanel. So the name server isn’t viewable now.

How to fix this issue? This picture May describe more my greed. I had just hidden My Ip Address and Domain Name in the screenshot.

From the screenshot above, the record:

  • CNAME www.admin (funtooza.com)

Would not work with :orange: due to explained in the below article (kindly change them to :grey: cloud).

You already have other on :grey: which is good.

If using cPanel, could you check if you have an SSL certificate installed at cPanel for your main domain and sub-domain(s)?
If yes, then under SSL options at Cloudflare dashboard, you should select Full SSL.

Do you have an MX record at Cloudflare DNS dashboard? - currently I do not see it.

Kindly, add an record MX funtooza.com with content value mail.funtooza.com and be it :grey: (DNS only).

Hello, Dear fritexvz
Thanks for your response. Appreciated :slight_smile:

  1. I have just checked my Cpanel. The SSL Certificates were activated sometime ago, but now they are expired. Let me share screenshots of my SSL-related Cpanel.
    White Area shows a piece of unwanted information about my site ie “IP” “Cpanel User Id” “Domain Name
    ssl ssl-1
  2. According to your valuable suggestion about MX, I was adding the same value which you have shared with me above, but keeping the “Priority” option empty is not saving the new entry. Kindly tell me What volume I should put in the PRIORITY box.

Dear @fritexvz
I Checked my SSL Certificate in detail on my Cpanel. Let me share with you a screenshot.
If I Uninstall the SSL certificate in my Cpanel, then the sound will be good?

Your SSL certificate as already stated needs to be renewed.
And it should cover your main domain and other sub-domain(s) too

Make all of your CNAME records :grey:, then if you used cPanel’s AutoSSL you can “Include all domains in AutoSSL” to generate an SSL certificate which would include all the needed and renew it.

After generating and if you can access your main domain and a sub-domains via HTTPS while the records are :grey:, then all good, turn the :grey: back to :orange: for CNAME yourdomain.com and CNAME www to make sure Full SSL mode is working propperly.

Thank you for your response dear @fritexvz
You suggested me below points;

@fritexvz: Your SSL certificate as already stated needs to be renewed.
And it should cover your main domain and other sub-domain(s) too
@MansoorJarwar110: So May I renew them first? As I have installed SSL of Cloudflare already so what will you say? May I go to renew it now?

@fritexvz: Make all of your CNAME records :grey:, then if you used cPanel’s AutoSSL you can “Include all domains in AutoSSL” to generate an SSL certificate which would include all the needed and renew it.
@MansoorJarwar110 You mean to say After renewing my SSL at web-hosting providers, then I come here on my Cloudflare’s dashboard and make CNAME records grey as they are already grey. if yes then how to make a CNAME grey? I don’t know the process and procedure!

@fritexvz: After generating and if you can access your main domain and a sub-domains via HTTPS while the records are :grey, then all good, turn the :grey: back to orange: for CNAME yourdomain.com and CNAME www to make sure Full SSL mode is working properly.

@MansoorJarwar110 FULL SSL means? Where? On My Hosting Cpanel or Cloudflare’s dashboard?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.