Getting 502 Bad Gateway while turning on SSL for Wordpress Website

ssl
dns

#1

Hi,

I’m getting 502 Bad Gateway error when turning on SSL for a Wordpress website hosted on Digital Ocean Cent OS 7 vps. Site works fine without SSL through Cloudflare, issue arises when Flexible SSL is turned on, it results in 502 Bad Gateway. It worked fine for a few months without any issues, problem seems to be occurring since yesterday when i had to update the DNS.

Funny thing is Another Wordpress website on the same server works perfectly fine with Cloudflare SSL without any sort of issues.

How do i diagnose this problem ? No errors are being logged by Apache on my server. Pls help !


#2

www on the three sites on your account seem to work for me. Are you still having this issue?


#3

Hi, MOD_SSL on my server was mysteriously turned off, just managed to discover that, reinstalling it solved the isssue for me. Thanks a lot !


#4

This topic was automatically closed after 14 days. New replies are no longer allowed.