Getting 404 Error Think it's DNS Settings

#1

Hi I’ve seen this problem around but no definite answer to the issue. My website anusupreme.com was working fine (other than not being secure) then I changed the name serves from my domains hoster to that of cloudflares and BOOM site goes down. I was told to wait but not it’s been over 24hours.

I know I don’t have correct dns settings just not sure how to fix this and if that’s the core issue. any help would greatly be appreciated’ Thanks!

0 Likes

#2

Can you share your DNS setting without revealing your IPs?

1 Like

#3

I’m not sure how to do that

0 Likes

#4

Take a screenshot form your Cloudflare panel like this one:

1 Like

#5

0 Likes

#6

As you see your configurations is not like the one I shared. You need an A Record to point your domain to your webserver:

A yourdomain.com x.x.x.x

Where x.x.x.x is the IP address of the machine where your domain is hosted. Without that entry your website won’t show up.

0 Likes

#7

Thats the only one I need? my domain is with godaddy but my hosting is with infinityfree

How can I find that ip address?

0 Likes

#8

What is your website address?

0 Likes

#9

anusupreme.com

0 Likes

#10
dig www.anusupreme.com +short
11776.bodis.com.
199.59.242.151

So your IP is 199.59.242.151 but currently your website www.anusupreme.com is not using Cloudfare (See here)

And your website address without www doesn’t have an A Record (See here)

You need to define an A Record for anusupreme.com and a CNAME for www.anusupreme.com. Like:

Type   Name                Value
=========================================
A      anusupreme.com      199.59.242.151
CNAME  www.anusupreme.com  anusupreme.com

Also you need to set the dns for www as provided to you by Cloudflare.

2 Likes

#11

Thank you’ I just added both of those.

Now what was the last one you said I had to add from cloudflare as well? where can I find this

0 Likes

#12

Forget about it. I have checked your website and it is good (also www).

0 Likes

#13

Interesting… because when I type my site up it’s just blank now. I have the https now though it’s just blank :thinking:

0 Likes

#14

Clear your browser cache and try again.

0 Likes

#15

Just did, same result. sheesh I was never sure how cloudflare could show/connect to your hosting site without any info from the hosting after changing domain nameservers to cf. This is a little frustrating

0 Likes

#16

CF just proxy traffic to your server. With those NS records you just added now CF knows where to send traffic. Is the picture I’ve posted your website? Then something is wrong at your client side.

0 Likes

#17

Hi @anusupreme3, I’d second that, I see the same thing @Xaq is showing. If that’s your site, try in incognito mode and/or clear your browser cache.

0 Likes

#18

This is my website.

When the orange clouds are turned off in the dns’s you gave me - this is what I get.
But when they’re turned on, I get secured https but just a blank page with nothing

0 Likes

#19

again my domain is registered with godaddy(where I changed nameservers to CF) and my hosting is with infinity free hosting.

I’ve seen others with this issue that when they’ve changed their nameservers from that of there hosting to CF that this happened. but most never seemed to have gotten it resolved and the few that did always had very little to say about how it was fixed with some even saying “IDK what happened but it’s working now lol”

0 Likes

#20

So what I was able to see is not website. Currently your website is pointing to Bodis and returns time out error.

Try this config:

Type   Name                Value
=========================================
CNAME   anusupreme.com     11776.bodis.com
CNAME  www.anusupreme.com  anusupreme.com

They have changed The IP

0 Likes