Getting 404 error that doesnt belong to my server

Hi, I started to use clouflare there is something like 2 days, and last night I began to have some 404 errors that doesn’t belong to my server.

Firstly all the request that ended up with this weird 404 error doesnt show up in nginx logs.
Secondly I never did this 404 page so that would be really weird that nginx decided to use a 404 page I never seen before by itself.
and finally I paused cloudflare for 1 hour and I did not get the error anymore, until I re-activate it.

This is strange because it’s not hapening every time, looks like you get it if you don’t request the page for something like 10 min, but when refreshing the page right after getting the 404 error page then it works normally. Also the favicon.ico is being loaded so it means the server can be reached.

I don’t understand why would I get a 404 page because from what I saw cloudflare doesn’t render 404 pages, but it’s still a fact that i’m getting one, i’ll send the page maybe someone did ever seen it, and if someone has an idea please don’t hesitate.

Check if all your DNS records are correct.

What’s the domain?

1 Like

As you suspect, it’s not Cloudflare. I recommend you open your browser’s Dev Tools (F12 in Chrome) and look at the Network Tab to see if any resources are loading from a familiar place.

1 Like

The domain is pics.hori.ovh and the IP is the good one.

I did it, I even managed to open it before it happen, to see the Network tab and actually there isnt something i’m familiar with, its using a google font and except of the favicon.ico there is nothing much, even the css is in the html itself.

Loads fine here. Assuming that’s what you expect.

Did you check if you might not have an outdated IP address on your end?

that what should be hapenning but I can swear that this 404 error is showing up regulary, at least on my side i get it after waiting for 15min without doing anything i would say.

How many IP addresses do you have for pics configured?

There is just one. Also even if cloudflare is configured for 3 subdomain it seems to happen only on this one even though I did not try with the others too much.

Any Workers? Was your domain previously configured for any service which could possibly use Cloudflare as well?

No I never used Cloudflare before, I moved from ovh DNS and it was working fine, but now i’m getting this error. I don’t really want to stop using cloudflare since the caching system really is helpful but seems the issue is definitly related to this, maybe not directly but it has something to do with it for sure. (I know it might be hard to believe but everything related to the IP is correct and it doesn’t reach the server when there is this error, so its pretty difficult to identify the issue.)

Also there is no workers configured

Running your site at sitemeer.com/#https://pics.hori.ovh I usually get 11.8 kilobytes, but occasionally also 17 kilobytes. That could be the 404.

I could reproduce the issue earlier briefly, but now not any more.

If you are saying you have

  • one IP address only
  • no Workers
  • had the domain never anywhere else configured where a Cloudflare configuration could still be active

then Cloudflare should really always proxy to your server and that 404 should come from there.

Do you have anything in front of your server (e.g. load balancer)? Do you have any other unusual configurations (e.g. HTTP 2 vs HTTP 1)? What about SSL? Which encryption mode do you have on Cloudflare?

Maybe you have some sort of rate limit which for whatever reason shows a 404. In that case it could be that the Cloudflare proxies run into that on your server. Check that too.

Thanks for your help really, I have an Apache server in front of the server itself, I didn’t mention it since i knew it will result in people telling me its maybe comming from the Apache, but even on the Apache log there isnt anything.

Its https between cloudflare and apache then reversed proxy in http to nginx and nginx reversed proxy it in http to a python framework. I’m using clouflare origin for https, I used to use lets’encrypt before but I changed it in a last hopes move.

I’ll check that thanks for the idea.

Check all the logs, not just your domain log. Based on what I mentioned earlier I’d rather rule out that this is coming from anywhere else than your server. Also, maybe set up SSL directly on Nginx and take Apache temporarily out of the equation, just to check that too.

I can’t remove Apache from the equation, it is listening on port 80 and really cant stop it. Also I looked on the main logs and there isnt anything in it.

I edit this message since i must wait 23h for creating a new one,Well it’s ok, to be honest I wasn’t expecting that much when comming there, I’ll still send the Apache virtual host configuration to show that there isnt anything strange. If you really want to reproduce it I’ll suggest to wait 10-20 min without trying to request and then retry, But i can give a lot of information on the page itself anyway, I did screenshots of the headers, and i even have the view-source tab opened on it right now.

<VirtualHost 192.168.1.10:443>
ServerName hori.ovh
ServerAlias *.hori.ovh
SSLEngine on
SSLCertificateFile /etc/cloudflare/hori.ovh.pem
SSLCertificateKeyFile /etc/cloudflare/hori.ovh.key
ProxyPreserveHost On
ProxyPass / http://192.168.1.33/
ProxyPassReverse / http://192.168.1.33/
RemoteIPHeader X-Forwarded-For
RemoteIPTrustedProxy 192.168.1.33

It doesnt appear on the logs when this error shows up (even if its a 200) I mean I tried it this morning and everytime i get this they werent ANY log for it at the moment (I can still see your other requests).

Here is the html content if it can help (just deleted it if you have it)

I dont have Argo since im with a free plan, I don’t know what is Railgun. And yes, I found it strange that the domain was in the href but i can swear i didn’t even did that page or even set something like that up. Do you think I should delete the site from cloudflare and try again then?

I just managed to get the error again and there is actually no header i think

Ok but idk when can i even open a ticket i saw that you cant open a ticket if you have a free plan.
I’ll firstly try to delete and setup again, if it doesnt i’ll try to open a ticket but as i just said ihave no idea of how should i process then. Also thanks a lot for your time and help i’m really grateful.

Ps: I just deleted the site and when I tried to add it again it actually imported the old config as it was but the pics domain isnt in it anymore, thats strange, maybe there really was an issue with it.
Update : deleting the site and adding it back did not fix the issue.

The ticket has been re-opened Thanks a lot for your help !

I am not sure that’s actually a 404. Sitemeer just got different content sizes again and it’s still a 200. Seems to be a 404 content served on a 200. Check your logs for requests to the root directory where the response is outside of the usual range.

Yep, the 404 is definitely still a 200, but with 17 kilobytes. I’d check the logs for that.

All right, it’s getting more interesting.

I just got a “404” response and there is no CF-Cache-Status header, which would suggest that was actually not served from your server but actually from Cloudflare (not even the cache).

At this point I’d really double check if your domain was added to any service which could possibly use Cloudflare and override your settings. You can also rule out that you ever activated Cloudflare Pages or Sites? Could you have enabled anything else, for example Argo or Railgun?

I have the content here. The only thing that is noticeable is that the link contains your actual domain, so - unless it takes the host header - it should be something that is aware of your domain and was configured for your domain.

You could try this. But if something got stuck, I am not sure deleting it will get it unstuck. But if you can quickly set it up again you might want to try.

Considering that you said you can rule out any unorthodox setup I’d open a support ticket with Cloudflare at this point because this would require actual insight into the request and only support has that kind of access.

Once you opened the ticket, reply twice to it, so that it actually reopens, but don’t expect an answer soon as it will still need to be pushed to support via the community because Cloudflare dropped support and everything requires manual escalation through MVPs at this point. With the weekend I’d expect a first answer Tuesday or Wednesday.

Just ran a check at Sitemeer and got on the first request almost everywhere 17 kilobytes.

IMHO something is stuck and support needs to clear that up.

Yes, you can open a ticket but it will be automatically closed, hence what I wrote earlier.

Continuing the discussion from Getting 404 error that doesnt belong to my server:

@arnaud1, continuing here because Discourse believes to have to be somewhat patronising today.

Maybe you can respond here again as well. No idea :man_shrugging:t2:

You configured a private address here. Are you absolutely sure Cloudflare connects directly to Apache?

Yes, that’s what I was referring to earlier.