Get build error incompatible node.js version

have setup next.js ecommerce site , getting the following build error when building on cloudfare.

error [email protected]: The engine "node" is incompatible with this module. Expected version ">=14.x". Got "12.18.0"

how & where can i configure which node version to be used for build ?

You can use the NODE_VERSION environment variable to change it.

1 Like

thanks. that was very helpful… where can i list of possible envrionment variables that may be required ?

The docs list the variables usable for languages and tools here: https://developers.cloudflare.com/pages/platform/build-configuration#language-support-and-tools

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.