Gatsby pages deployment error

NestedError: Cannot copy from .cache/.eslintrc.json to /opt/build/cache/cwd 11:16:03.944 /.cache/.eslintrc.json: Cannot create directory /opt/build/cache/cwd/.cache
11:16:03.944 : EACCES: permission denied, mkdir ‘/opt/build/cache’
11:16:03.945 - index.js:274 pMap.concurrency.concurrency
11:16:03.945 [adapters]/[cpy]/index.js:274:12
11:16:03.945 - index.js:141
11:16:03.945 [adapters]/[p-map]/index.js:141:20
11:16:03.946 - Caused By: NestedError: Cannot create directory /opt/build/cache/cwd/.cache 11:16:03.946 : EACCES: permission denied, mkdir ‘/opt/build/cache’
11:16:03.946 - fs.js:61
11:16:03.947 [adapters]/[cp-file]/fs.js:61:8
11:16:03.947 - index.js:15 cpFileAsync
11:16:03.947 [adapters]/[cp-file]/index.js:15:2
11:16:03.948 - index.js:269 pMap.concurrency.concurrency
11:16:03.948 [adapters]/[cpy]/index.js:269:6
11:16:03.948 - index.js:141
11:16:03.948 [adapters]/[p-map]/index.js:141:20
11:16:03.949 - Caused By: Error: EACCES: permission denied, mkdir ‘/opt/build/cache’
11:16:03.950 Pages

We are experiencing the same problem in our deployments since Sep 13…

1 Like

This issue when using Node v18.18.0

Previously i used Node v17.9.0 no issue.


Can you try the v2 build system - → “Build system version” → v2

If the issue persists, please provide the deployment ID (the UUID in the URL when viewing a deployment in the dash)

1 Like

which node versoin you are using?

Hi,Thanks for your recommendation i changed to v2 now i’m getting below error.

|20:33:50.135|Executing user command: gatsby build|
|20:33:50.141|/bin/sh: 1: gatsby: not found|
|20:33:50.142|Failed: Error while executing user command. Exited with error code: 127|
|20:33:50.152|Failed: build command exited with code: 1|
|20:33:52.218|Failed: error occurred while running build command|

Ah yes, you’ll need to update the build command to npx gatsy build or add a build script in package.json and use that

1 Like

we are on 18.16.0. And it worked fine until Sep 13. I don’t think it’s node 17 vs 18 problem. Something else. And I got the same error as you did when trying V2. Really think it’s the same problem for both of us

yes used npx gatsby build. now this error
Failed: multple times.
error 1: an internal error occurred. If this continues, contact support:
error 2 : public folder not found

after retry the deployment 3 times now deplyment is successfully but issue is strange behaviour. :grinning:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.