Gateway for Android


I have problem when using app on android, when I have enabled WARP/Gateway or only DNS mode my internet stops working after few minutes… I want to use Gateway but I can’t do this with app, so, can I use Gateway location TLS address with Android’s “Private DNS”?

1 Like

can you go to Advanced->Connection Options and try Reset encryption keys.
Do you have this problem on your home internet or mobile internet?

I tried Reset security keys but same problem, this happens on every network, on home wifi, on mobile internet, on work wifi… I have this problem from launch of app… Same on Samsung J3 (Android 9), on Samsung A41 (Android 10) with 6.3 app version… Sometime I see “Your internet is protected” on home page, but internet not works… Sometime I see “Your network wants you to sign in”…

App not works for me, so, can I use Gateway location DoT address with Android’s “Private DNS” feature or not?

Hmm if DotMrCode’s solution didn’t work we’ll need to take a look at the logs. Can you please file a ticket and put your name here somewhere in the subject for description so I can find it?

@datoshkr Have you tried using to confirm you’re able to use DoT with


I want to use Gateway and block some website…

Hi @datoshkr, let’s confirm that you are able to connect to any resolver via DoT. Can you try with and post the results of the test?

Yes of course

How to file a ticket?

In the app you can click the little bug icon or find the Send Feedback off preferences.

I did this a few days ago

@datoshkr I confirmed I could enforce DNS policies when I input my DoT endpoint in the Private DNS setting on Android 11. Just select a DoT hostname from a location on your account (looks like you did so in the first screenshot) and your queries will be filtered according to any policy you have aligned with that location.

I don’t have to use the warp application for DNS filtering. I can just use DNS over TLS. Is this understanding correct?

I have to ask because with the DNS over TLS setup, if I run a DNS query, I don’t see the domain name in the Gateway logs. I’m running a DNS leak test at and I’m expecting that particular domain to appear on the Gateway logs, but it doesn’t happen.

Disregard, the logs appear okay. It just needed a minute to populate!