Garmin Index Smart Scale drops connections when using

Whenever I setup my router to use Cloudflare’s public DNS service, my Garmin Index Smart Scale stops connecting to the internet. It was really hard to pin down because it would continue to work for “a while” until its internal cache expired, but it turns out I’m not the only person experiencing this. Unfortunately, Garmin has not solved this issue in two years, so I’m wondering if there’s a way for Cloudflare to either workaround it, or pressure Garmin to actually solve their bug. I was able to sync my scale and get its software updated to version 3.20 by changing my router’s DNS to use Quad9, but any time I try to go back to the scale eventually stops connecting. For what it’s worth, this happens with both basic DNS and when using a DNS-over-TLS setup. I also have an open support ticket of my own with Garmin I can use to pass any information along.

Have you tried instead?

Yes, the configuration included both and, and an IPv6 configuration of 2606:4700:4700::1111 and 2606:4700:4700::1001 per the instructions.

Hey @user1062!

Does using only IPv4 help? I’ve been facing issues with IPv6 as seen here:

Hi! Are you able to figure out which domain names is it querying? I can take a look, but would need to figure out what is the scale querying first, as I don’t have it to test.

1 Like

What would be the best way to get that data? I’m thinking…I could setup and use its logs to capture it? As far as I can tell my router does not have DNS logging capabilities.

I guess if you’re not able to capture the traffic yourself with wireshark etc. that’s also an option!

1 Like

I hate to be that person, but before I got around to firing up WireShark for the first time in a decade :sweat_smile: …the problem has gone away. It’s connecting fine now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.