Gallery not working in Elementor pro

Hello Guys,

My WordPress installation is hosted at Aws lightsail and build with Elementor pro, I did the Cloudflare health check and everything is green. The site is up, but I have one important issue:

When I insert a gallery on a page I can’t access Elementor editor for that page anymore !!??
I spent ten days with the Elementor support, and they can’t reproduce the issue with my WP installation on their server, so they think it should come from Cloudflare and probably related to the base64 images, like say in this post Err_http2_protocol_error

I can’t find a way to fix it !!!
Any help would be awesome
thanks in advance

Deos it have some caching at it’s end?

Do you have some output at the console, or some errors appearing while loading the Elementor assets/resources?
Maybe some or more of the resources are being blocked or something else due to either security or firewall, or triggers some JS challenge at Cloudflare end?

Have you got Rocket Loader enabled at Cloudflare “Speed → Optimization”?
Maybe this Page Rules for Cloudflare as described here can help you:

Those instructions only specify the match, but not the needed action. They probably want that Page Rule to disable Rocket Loader for the matching URLs if so.

Moreover, have you tried using a search to find any helpful information or related fix?:
https://community.cloudflare.com/search?q=elementor

Can you host your images yourself?

Hi, thank you for your quick answer.

On my setup AWS don’t have the page to manage cache, so I only have reboot function

I have this for the non-working pages

Uncaught ReferenceError: post.php?post=1668&action=elementor:3841
elementorCommon is not defined
at HTMLAnchorElement. (post.php?post=1668&action=elementor:3841)
at HTMLAnchorElement.dispatch (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-mouse,wp-api-request&ver=5.7:4)
at HTMLAnchorElement.v.handle (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-mouse,wp-api-request&ver=5.7:4)

I don’t have rocket Loader enabled, but to try I just
-switching it on
-Set the following rule for one of the problematic pages

Cache Level: Bypass
-Purge everything cache from Cloudflare wp plugin

  • wait 1 minute or so
    -clear browser cache
    -try to access the page with elementor editor
    Still not working :frowning:

I did before posting it, but I didn’t found any similar topic.
It’s the elemnentor support tech that told me that my error is related to this post Err_http2_protocol_error

Sure, but what’s the benefit of Cloudflare if I can’t cache the images ?
However, I’d like to try to see if it’s better but not sure how to set up this?

please let me know
thanks

This topic was automatically closed after 29 days. New replies are no longer allowed.