G Suite MX Records Disappearing

#1

I just finished migrating over to a new host and set everything back up as new. I’ve tried now twice to add the G Suite records but both times they simply disappear. The email works for a solid 5 minutes before the records are deleted and it stops working. Any help would be greatly appreciated.

https://support.google.com/a/answer/174125?hl=en

0 Likes

#2

Knowing the domain name would be a first step. A screenshot of the DNS settings a second. Can’t help you without those as that doesn’t happen to me not to anyone else I know about.

0 Likes

#3

I’ve solved the issue. When transferring everything for some reason my google verification cname and txt were dropped. I couldn’t figure out how to find them through g suite but luckily I had a backup of my DNS records. I just imported the file and everything was fixed. It’s been about an hour and they haven’t disappeared again.

1 Like

#4

Cross that, they just disappeared again alongside the cname and txt I added. Email once again stopped working.


Those are the current records with the new gone. Here are the ones that keep disappearing. The MX are taken from the cloudflare link above and the rest were in my backup.

I’ve also been deleting the MX record “mail handled by evbite.com” which keeps popping back up when the others are deleted.

0 Likes

#5

Well, I have never seen that happening.

Are you sure no one has your API key? Look in the audit log to see who changed the records, if they were changed at all.

1 Like

#6

Pretty sure no one has my API but I just changed them just in case. Audit log is showing as me deleting the files which is clearly not the case. I just imported the records for a 3rd time and everything is once again working fine. I guess I’ll come back in a few hours if they get deleted again. I have no idea what’s going on…

0 Likes

#7

It’s working now, I see that. In case I would contact support, not us in the community. We can’t really see what’s happening from the community.

Please do let me know if it reverts though.

0 Likes

#8

I’ll contact support if/when it happens again. Who knows, maybe resetting the API will fix it. I’m just going to have to wait it out. I’ll be sure to update you.

1 Like

#9

Resetting the API seemed to finally fix it. It’s been almost a day and it hasn’t reset. Thanks for the help

1 Like

#10

Good to know!

0 Likes