Functions (pages) - deployment issue


There was a huge issue with functions in the pages project.

The functions stopped working at 11:03, which corresponds to the completion of the deployment process at 11:00.
As soon as we noticed the functions no longer worked, we tried clicking in the Cloudflare UI and redeploying, which fixed the problem.

Due to the fact that the deployment process and redeployment are related to the cloudflare, and the version that was deployed and re-deployed is the same.

We urge you to investigate what happened here. Since this is the first time we see such an issue after deployment, we are not sure whether to stop auto deployments.

We really need more details here. What’s the What error did you see in the Function? Have you done any debug?

Without that, we couldn’t say what happened here.

the =
We didn’t see any error
It just stopped working after deployment

So, looking our side, I can see no errors or issues. Your Function also seems to have had 0 problems. I do see a dip in requests in the dashboard analytics at 8am UTC. However, from our analytics I can see the requests actually maintaining a steady level.

Looking at the deployments, which is the bad one? I see 938caef9-15f0-41f9-9e6b-752d73ccafff which I believe is the one since it seems to line up with what I can find. This one correctly did deploy the Functions, subsequent deployments which I believe are you retrying got skipped and never actually deployed.

You also seem to have deployed many time since then without issues.

So from what I can tell, the dash analytics seem to be lying a little but from what I can see on our side, everything is ok.

1 Like

Thank you for investigating,
This function determines what HTML to respond with. When the function did not work, the whole site did not work.
We cannot allow ourselves to lose so much again without understanding what happened. Although we trust pages project, deploying and then redeploying the same code made different results in your system. Deploying stopped functions and re-deploying fixed it.

In order to prevent it from happening again, we must understand the issue

Again, I need more information if I want to look into it more. I still don’t know for sure what deployment you seemed to see this issue on. Is it the one I sent?
And what did you see when you went to the site? Was there an error? What status code?

From my look today, everything functioned as it should, everything got deployed as it should. However, I still don’t know what happened, when and on what deployment so my understanding is from what I found only.