Full (strict) mode problem

Hello,
I have one synology nas device. I cannot go to the https address of Synology Drive application from the outside world. I activated full strict mode from SSL mode option. I redirected all connections to https. I created an origin certificate. I imported .key, .pem and origin_ca_rsa_root.pem file to the nas device. I have selected CF certificate as default on the NAS. I am accessing using Cloudflared container. If I select No TLS Verify option as below, I can access the Drive.

But I want it to access with end-to-end certificate verification without selecting it. How can I do this?

solved thanks.

Can you share how you solved it for the benefit anyone who has a similar problem and finds your topic?

Of course.I typed the name of my subdomain in the “Origin Server Name” field at the top. Problem solved.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.