FTP not working, even changed DNS records to unproxy ftp

I have seen that the issue is with the proxy, so I went ahead “unproxied” the CNAME record for ftp, left if for days, and it’s not working, then went ahead and created an A record without the proxy option as stated in other thread, still not working after days.

What am I missing? I am using WinSCP as I have done for years.

Welcome to the Cloudflare Community.

It sounds like your first steps were sound. Any more specific suggestions will require knowing the domain and any relevant hostnames.

You can share the domain by placing a single backtick ` before and after it so that it will be formatted like example.com.

Of course, my domain is armenuii.com.

I have added other subdomain and everything with no issues, but FTP doesn’t budge, I went back to using CNAME to give it another try.

any help will be greatly appreciated

Don’t use a CNAME. As long as your CNAME resolves to a :orange: proxied host, it will not work.

Create an A record for your ftp hostname and use your cPanel server IP. That will ensure that everything is set up correctly on the Cloudflare side.

That doesn’t mean that required services will be running on the cPanel host, but you should be able to review your settings with your host to check that.


More useful information:

Nevertheless, from the screenshot you’ve shared, there is another thing related to the e-mail.

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

Also, make sure that autoconfig, autodiscover are unproxied too and set to :grey:


Alright makes sense, I had tried using the A record for a few days and didn’t work.

BUT I finally saw my mistake, I was trying to log in as usual with the domain name, not the IP in the client, I changed that and it’s working great now!

Thank you a lot, I can finally sleep easy.

The MX records don’t really matter at the moment, they just got migrated from Godaddy like that, the domain doesn’t really have emailing enabled, but that’s great information that I will use in the near future.

As long as you use the FQDN of ftp.example.com you should be fine. If you were just using the apex name example.com then you never would have been connecting to the unproxied ftp hostname.

Ah I see, it never occurred to me since I seldom have had to use FQDN, but it makes so much sense, I really appreciate it, thank you!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.