FTP/FTPS via Tunnel


is there anyone who is using FTP/FTPS (FTP over SSL) via cloudflared/tunnel? I am struggling with data corruption during binary file transfers.

The tunnel is working fine for other protocols, but files transferred via FTP in passive mode are being corrupted โ€“ incomplete. Happens usually for files larger than 2 MB at the end of the transfer. Not deterministic, the same file is sometimes transferred correctly and sometimes corrupted. Not rare, occurs in like half of the cases.

I have tried multiple cloudflared hosts (linux/Windows), multiple target FTP servers (Linux/Windows), networks and multiple clients (Total commander, WinSCP, FileZilla). All of them have the same issue.

The client is using WARP Zero Trust to access the tunnel. I have tried multiple versions of cloudflared (including latest January release) and multiple versions of WARP and nothing is transferring the files correctly.

Nothing useful in cloudflared not warp logs :frowning:


1 Like

May I ask how does your config.yml file look like? Like:

hostname: ftp.yourdomain.com
service: ftp://your-internal-ftp-ip:21

However, I am quite not sure if it possible to use it for FTP :thinking:
At least, not on free plan. Could be I am wrong. Have to try it.

I am sorry to hear that.

The tunnel is configured based on Via the command line ยท Cloudflare Zero Trust docs

The config.yml contains only

tunnel: <Tunnel-UUID>
credentials-file: /root/.cloudflared/<Tunnel-UUID>.json
  enabled: true

The route is added by

cloudflared tunnel route ip add <IP/CIDR> <UUID or NAME>

From my understanding the tunnel should support any TCP traffic, so it does not matter if it is FTP or other protocol.

The free plan should be irrelevant โ€“ Zero Trust Services Plans & Pricing
No problem switching to a paid plan, but I doubt it makes a difference.

This is still very much an issue, that seems to have been forgotten by Cloudflare in the GitHub Issue

Are there any chance this will be fixed?

1 Like